aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-system-monitor
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/gnome-system-monitor')
-rw-r--r--sysutils/gnome-system-monitor/Makefile11
-rw-r--r--sysutils/gnome-system-monitor/distinfo6
-rw-r--r--sysutils/gnome-system-monitor/files/patch-src_load-graph.cpp11
-rw-r--r--sysutils/gnome-system-monitor/pkg-plist8
4 files changed, 26 insertions, 10 deletions
diff --git a/sysutils/gnome-system-monitor/Makefile b/sysutils/gnome-system-monitor/Makefile
index 5bb1ec109e92..fbb8efd729fc 100644
--- a/sysutils/gnome-system-monitor/Makefile
+++ b/sysutils/gnome-system-monitor/Makefile
@@ -3,14 +3,13 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/sysutils/gnome-system-monitor/Makefile,v 1.109 2007/10/15 21:02:38 mezz Exp $
+# $MCom: ports/sysutils/gnome-system-monitor/Makefile,v 1.117 2008/03/10 22:04:22 mezz Exp $
#
PORTNAME= gnome-system-monitor
-PORTVERSION= 2.20.2
+PORTVERSION= 2.22.0
CATEGORIES= sysutils gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-system-monitor/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
+MASTER_SITES= GNOME
DISTNAME= gnome-system-monitor-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -19,7 +18,6 @@ COMMENT= GNOME 2 system monitor program
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme
LIB_DEPENDS= gtop-2.0.7:${PORTSDIR}/devel/libgtop \
- pcre.0:${PORTSDIR}/devel/pcre \
gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme
@@ -28,7 +26,8 @@ USE_GETTEXT= yes
USE_XLIB= yes
INSTALLS_OMF= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix intlhack gnomehack libwnck gnomevfs2 gnomedocutils
+USE_GNOME= gnomeprefix intlhack gnomehack libwnck gnomevfs2 gnomedocutils \
+ librsvg2
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-pcrecpp
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/sysutils/gnome-system-monitor/distinfo b/sysutils/gnome-system-monitor/distinfo
index 7e3b1ee00341..d8b8f50d4c69 100644
--- a/sysutils/gnome-system-monitor/distinfo
+++ b/sysutils/gnome-system-monitor/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-system-monitor-2.20.2.tar.bz2) = d5e52f923b0b725b3a49e4bb7a296436
-SHA256 (gnome2/gnome-system-monitor-2.20.2.tar.bz2) = 2829da0e37a0758b949d4a59ab22e71b6372b9e3cc6bb907aa95e2d375ccbedc
-SIZE (gnome2/gnome-system-monitor-2.20.2.tar.bz2) = 1827859
+MD5 (gnome2/gnome-system-monitor-2.22.0.tar.bz2) = 7b809a4db72902ca5f47a63f62917d14
+SHA256 (gnome2/gnome-system-monitor-2.22.0.tar.bz2) = a2e6b6c185063fc43e6d6293a64cd3fa6f32be58b682bc58e5913c94aa3cd1e2
+SIZE (gnome2/gnome-system-monitor-2.22.0.tar.bz2) = 1935178
diff --git a/sysutils/gnome-system-monitor/files/patch-src_load-graph.cpp b/sysutils/gnome-system-monitor/files/patch-src_load-graph.cpp
new file mode 100644
index 000000000000..e57a2170425e
--- /dev/null
+++ b/sysutils/gnome-system-monitor/files/patch-src_load-graph.cpp
@@ -0,0 +1,11 @@
+--- src/load-graph.cpp.orig 2008-01-14 23:43:43.000000000 -0600
++++ src/load-graph.cpp 2008-01-14 23:44:15.000000000 -0600
+@@ -501,7 +501,7 @@
+ // e.g: ceil(100.5 KiB) = 101 KiB = 101 * 2**(1 * 10)
+ // where base10 = 1, coef10 = 101, pow2 = 16
+
+- unsigned pow2 = std::floor(log2(new_max));
++ unsigned pow2 = std::floor(log(new_max) / log(2));
+ unsigned base10 = pow2 / 10;
+ unsigned coef10 = std::ceil(new_max / double(1UL << (base10 * 10)));
+ g_assert(new_max <= (coef10 * (1UL << (base10 * 10))));
diff --git a/sysutils/gnome-system-monitor/pkg-plist b/sysutils/gnome-system-monitor/pkg-plist
index f099100907d6..4ed8d93f72d6 100644
--- a/sysutils/gnome-system-monitor/pkg-plist
+++ b/sysutils/gnome-system-monitor/pkg-plist
@@ -117,6 +117,7 @@ share/locale/am/LC_MESSAGES/gnome-system-monitor.mo
share/locale/ar/LC_MESSAGES/gnome-system-monitor.mo
share/locale/az/LC_MESSAGES/gnome-system-monitor.mo
share/locale/be/LC_MESSAGES/gnome-system-monitor.mo
+share/locale/be@latin/LC_MESSAGES/gnome-system-monitor.mo
share/locale/bg/LC_MESSAGES/gnome-system-monitor.mo
share/locale/bn/LC_MESSAGES/gnome-system-monitor.mo
share/locale/bn_IN/LC_MESSAGES/gnome-system-monitor.mo
@@ -147,6 +148,7 @@ share/locale/id/LC_MESSAGES/gnome-system-monitor.mo
share/locale/it/LC_MESSAGES/gnome-system-monitor.mo
share/locale/ja/LC_MESSAGES/gnome-system-monitor.mo
share/locale/ka/LC_MESSAGES/gnome-system-monitor.mo
+share/locale/kn/LC_MESSAGES/gnome-system-monitor.mo
share/locale/ko/LC_MESSAGES/gnome-system-monitor.mo
share/locale/ku/LC_MESSAGES/gnome-system-monitor.mo
share/locale/li/LC_MESSAGES/gnome-system-monitor.mo
@@ -196,7 +198,9 @@ share/omf/gnome-system-monitor/gnome-system-monitor-fr.omf
share/omf/gnome-system-monitor/gnome-system-monitor-oc.omf
share/omf/gnome-system-monitor/gnome-system-monitor-pa.omf
share/omf/gnome-system-monitor/gnome-system-monitor-sv.omf
+share/pixmaps/gnome-system-monitor/download.svg
share/pixmaps/gnome-system-monitor/side.png
+share/pixmaps/gnome-system-monitor/upload.svg
@dirrm share/pixmaps/gnome-system-monitor
@dirrm share/omf/gnome-system-monitor
@dirrm share/gnome/help/gnome-system-monitor/sv/figures
@@ -216,6 +220,7 @@ share/pixmaps/gnome-system-monitor/side.png
@dirrm share/gnome/help/gnome-system-monitor/C/figures
@dirrm share/gnome/help/gnome-system-monitor/C
@dirrm share/gnome/help/gnome-system-monitor
+@dirrmtry share/applications
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/ug/LC_MESSAGES
@@ -238,4 +243,5 @@ share/pixmaps/gnome-system-monitor/side.png
@dirrmtry share/locale/dz
@dirrmtry share/locale/bn_IN/LC_MESSAGES
@dirrmtry share/locale/bn_IN
-@dirrmtry share/applications
+@dirrmtry share/locale/be@latin/LC_MESSAGES
+@dirrmtry share/locale/be@latin