aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnomecontrolcenter2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/gnomecontrolcenter2/Makefile')
-rw-r--r--sysutils/gnomecontrolcenter2/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/sysutils/gnomecontrolcenter2/Makefile b/sysutils/gnomecontrolcenter2/Makefile
index a740f6b1916c..5af729474976 100644
--- a/sysutils/gnomecontrolcenter2/Makefile
+++ b/sysutils/gnomecontrolcenter2/Makefile
@@ -6,25 +6,29 @@
#
PORTNAME= gnomecontrolcenter2
-PORTVERSION= 2.2.2
+PORTVERSION= 2.4.0
CATEGORIES= sysutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/control-center/2.2
+MASTER_SITE_SUBDIR= sources/control-center/2.4
DISTNAME= control-center-${PORTVERSION}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= Control center for GNOME 2.0 project
+COMMENT= Control center for GNOME 2 project
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNOME_DESKTOP_VERSION=2
-USE_GNOME= gnomeprefix gnomehack gnomehier gnomedesktop metacity
-USE_LIBTOOL= yes
+USE_GNOME= gnomeprefix gnomehack gnomehier metacity nautilus2
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|[{]prefix[}]/share/pixmaps|{datadir}/pixmaps|g'
.include <bsd.port.mk>