aboutsummaryrefslogtreecommitdiff
path: root/sysutils/goawk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/goawk/Makefile')
-rw-r--r--sysutils/goawk/Makefile12
1 files changed, 2 insertions, 10 deletions
diff --git a/sysutils/goawk/Makefile b/sysutils/goawk/Makefile
index 214348535ab5..174ca8914bbd 100644
--- a/sysutils/goawk/Makefile
+++ b/sysutils/goawk/Makefile
@@ -9,22 +9,14 @@ MAINTAINER= yuri@FreeBSD.org
COMMENT= AWK interpreter written in Go
LICENSE= MIT
-LICENSE_FILE= ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/LICENSE.txt
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
USES= go
-USE_GITHUB= nodefault # the main code is in GH_TUPLE
+USE_GITHUB= yes
GH_ACCOUNT= benhoyt
-GH_TUPLE= benhoyt:goawk:${DISTVERSIONFULL}:main/src/github.com/benhoyt/goawk
GH_SUBDIR= src/github.com/${GH_ACCOUNT}/${PORTNAME}
PLIST_FILES= bin/${PORTNAME}
-do-build:
- @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME} && \
- ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go install ./...
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
-
.include <bsd.port.mk>