aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hal/files/patch-hald_freebsd_addons_Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/hal/files/patch-hald_freebsd_addons_Makefile.in')
-rw-r--r--sysutils/hal/files/patch-hald_freebsd_addons_Makefile.in13
1 files changed, 7 insertions, 6 deletions
diff --git a/sysutils/hal/files/patch-hald_freebsd_addons_Makefile.in b/sysutils/hal/files/patch-hald_freebsd_addons_Makefile.in
index beb677fa943a..f554c0650f3e 100644
--- a/sysutils/hal/files/patch-hald_freebsd_addons_Makefile.in
+++ b/sysutils/hal/files/patch-hald_freebsd_addons_Makefile.in
@@ -1,5 +1,5 @@
---- hald/freebsd/addons/Makefile.in.orig 2008-03-27 00:45:50.000000000 -0400
-+++ hald/freebsd/addons/Makefile.in 2008-03-27 00:48:15.000000000 -0400
+--- hald/freebsd/addons/Makefile.in.orig 2008-12-13 12:08:36.000000000 -0500
++++ hald/freebsd/addons/Makefile.in 2008-12-20 21:16:41.000000000 -0500
@@ -33,7 +33,8 @@ POST_UNINSTALL = :
build_triplet = @build@
host_triplet = @host@
@@ -39,19 +39,20 @@
ETAGS = etags
CTAGS = ctags
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
-@@ -227,6 +239,11 @@ hald_addon_storage_SOURCES = addon-stora
+@@ -229,6 +241,12 @@ hald_addon_storage_SOURCES = addon-stora
hald_addon_storage_LDADD = \
$(top_builddir)/hald/freebsd/libprobe/libhald_freebsd_probe.la
+hald_addon_mouse_sysmouse_SOURCES = addon-mouse.c
+hald_addon_mouse_sysmouse_CFLAGS = $(AM_CPPFLAGS) @GLIB_CFLAGS@
+hald_addon_mouse_sysmouse_LDADD = @GLIB_LIBS@ \
++ -lutil \
+ $(top_builddir)/hald/freebsd/libprobe/libhald_freebsd_probe.la
+
all: all-am
.SUFFIXES:
-@@ -288,6 +305,9 @@ clean-libexecPROGRAMS:
+@@ -290,6 +308,9 @@ clean-libexecPROGRAMS:
echo " rm -f $$p $$f"; \
rm -f $$p $$f ; \
done
@@ -61,7 +62,7 @@
hald-addon-storage$(EXEEXT): $(hald_addon_storage_OBJECTS) $(hald_addon_storage_DEPENDENCIES)
@rm -f hald-addon-storage$(EXEEXT)
$(LINK) $(hald_addon_storage_OBJECTS) $(hald_addon_storage_LDADD) $(LIBS)
-@@ -299,6 +319,7 @@ distclean-compile:
+@@ -301,6 +322,7 @@ distclean-compile:
-rm -f *.tab.c
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/addon-storage.Po@am__quote@
@@ -69,7 +70,7 @@
.c.o:
@am__fastdepCC_TRUE@ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ $<
-@@ -321,6 +342,20 @@ distclean-compile:
+@@ -323,6 +345,20 @@ distclean-compile:
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(LTCOMPILE) -c -o $@ $<