aboutsummaryrefslogtreecommitdiff
path: root/sysutils/hploscripts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/hploscripts/Makefile')
-rw-r--r--sysutils/hploscripts/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/sysutils/hploscripts/Makefile b/sysutils/hploscripts/Makefile
new file mode 100644
index 000000000000..c0b551d82673
--- /dev/null
+++ b/sysutils/hploscripts/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: hploscripts
+# Date created: 11 Feb 2010
+# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hploscripts
+PORTVERSION= 2.40.0
+CATEGORIES= sysutils perl5
+MASTER_SITES= CRITICAL
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= HP Lights-Out management perl scripts
+
+BUILD_DEPENDS= p5-IO-Socket-SSL>=1.19:${PORTSDIR}/security/p5-IO-Socket-SSL
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= 5.8.0+
+NO_BUILD= yes
+
+PORTDOCS= iLO_perl_xml.pdf linux-LOsamplescripts2.40.0-1.txt
+
+post-patch:
+ @${REINPLACE_CMD} -e '1s|.*|#!${PERL}|' ${WRKSRC}/locfg.pl \
+ ${WRKSRC}/vspconfig.pl
+
+do-install:
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.xml ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/hponcfg_reformat.xsl ${EXAMPLESDIR}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/iLO_perl_xml.pdf ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/linux-LOsamplescripts2.40.0-1.txt ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/locfg.pl ${PREFIX}/bin/locfg
+ ${INSTALL_SCRIPT} ${WRKSRC}/vspconfig.pl ${PREFIX}/bin/vspconfig
+
+regression-test: build
+ @${PERL} -c ${WRKSRC}/locfg.pl
+ @${PERL} -c ${WRKSRC}/vspconfig.pl
+
+.include <bsd.port.mk>