aboutsummaryrefslogtreecommitdiff
path: root/sysutils/idled/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/idled/Makefile')
-rw-r--r--sysutils/idled/Makefile23
1 files changed, 17 insertions, 6 deletions
diff --git a/sysutils/idled/Makefile b/sysutils/idled/Makefile
index 437abecb218b..0bbdfa9f56c8 100644
--- a/sysutils/idled/Makefile
+++ b/sysutils/idled/Makefile
@@ -7,7 +7,7 @@
PORTNAME= idled
PORTVERSION= 1.16
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://www.darkwing.com/idled/download/ \
ftp://ftp.cs.hope.edu/pub/idled/
@@ -20,14 +20,25 @@ MANCOMPRESSED= yes
MAN5= idled.cf.5
MAN8= idled.8
+SED_SCRIPT= -e 's|%%PREFIX%%|${PREFIX}|g'
+
+USE_RC_SUBR= yes
+RC_DIR= ${PREFIX}/etc/rc.d
+RC_SUFX= .sh
+SED_SCRIPT+= -e 's|%%RC_SUBR%%|${RC_SUBR}|g' \
+ -e 's|%%RC_DIR%%|${RC_DIR}|g' \
+ -e 's|%%RC_SUFX%%|${RC_SUFX}|g'
+PLIST_SUB+= RC_DIR=${RC_DIR} \
+ RC_SUFX=${RC_SUFX}
+
post-extract:
(cd ${WRKSRC}; make clean)
+post-build:
+ @${SED} ${SED_SCRIPT} ${FILESDIR}/idled.sh >${WRKDIR}/idled.sh
+
post-install:
- ${STRIP_CMD} ${PREFIX}/libexec/idled
-.if !exists(${PREFIX}/etc/rc.d/idled.sh)
- @${ECHO} "Installing ${PREFIX}/etc/rc.d/idled.sh startup script."
- ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/idled.sh ${PREFIX}/etc/rc.d/idled.sh
-.endif
+ @${INSTALL_SCRIPT} ${WRKDIR}/idled.sh ${RC_DIR}/idled${RC_SUFX}
+ @${STRIP_CMD} ${PREFIX}/libexec/idled
.include <bsd.port.mk>