aboutsummaryrefslogtreecommitdiff
path: root/sysutils/jps/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/jps/Makefile')
-rw-r--r--sysutils/jps/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/sysutils/jps/Makefile b/sysutils/jps/Makefile
new file mode 100644
index 000000000000..84fd06790d78
--- /dev/null
+++ b/sysutils/jps/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: jps
+# Date created: 27 March 2004
+# Whom: Pavel Novikov
+#
+# $FreeBSD$
+#
+
+PORTNAME= jps
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= http://ext.by/jps/
+
+MAINTAINER= pavel@ext.by
+COMMENT= Wrapper to ps(1) that maps pids to jails
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Term/ReadKey.pm:${PORTSDIR}/devel/p5-Term-ReadKey
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN1= jps.1
+MANCOMPRESSED= yes
+PLIST_FILES= bin/jps
+
+.include <bsd.port.mk>