aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ksysguardd/files/patch-FreeBSD__CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/ksysguardd/files/patch-FreeBSD__CMakeLists.txt')
-rw-r--r--sysutils/ksysguardd/files/patch-FreeBSD__CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/sysutils/ksysguardd/files/patch-FreeBSD__CMakeLists.txt b/sysutils/ksysguardd/files/patch-FreeBSD__CMakeLists.txt
new file mode 100644
index 000000000000..31e279c2c898
--- /dev/null
+++ b/sysutils/ksysguardd/files/patch-FreeBSD__CMakeLists.txt
@@ -0,0 +1,23 @@
+--- FreeBSD/CMakeLists.txt 2011-03-17 20:50:04.000000000 +0200
++++ FreeBSD/CMakeLists.txt 2011-03-07 18:04:26.000000000 +0200
+@@ -1,14 +1,16 @@
+ INCLUDE_DIRECTORIES( ${CMAKE_CURRENT_SOURCE_DIR}/../CContLib ${CMAKE_CURRENT_SOURCE_DIR}/../ )
+
+-ADD_LIBRARY(libksysguardd STATIC
++ADD_LIBRARY(libksysguardd STATIC
++ acpi.c
+ apm.c
+- CPU.c
++ cpuinfo.c
+ diskstat.c
+ loadavg.c
+ logfile.c
+ Memory.c
+ netdev.c
+- ProcessList.c)
++ ProcessList.c
++ stat.c
++ uptime.c)
+
+ TARGET_LINK_LIBRARIES(libksysguardd kvm)
+-