aboutsummaryrefslogtreecommitdiff
path: root/sysutils/ledit
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/ledit')
-rw-r--r--sysutils/ledit/Makefile32
-rw-r--r--sysutils/ledit/distinfo6
-rw-r--r--sysutils/ledit/files/patch-pa_local.ml15
-rw-r--r--sysutils/ledit/pkg-descr4
4 files changed, 30 insertions, 27 deletions
diff --git a/sysutils/ledit/Makefile b/sysutils/ledit/Makefile
index ad8c6421d26e..b622865e4a67 100644
--- a/sysutils/ledit/Makefile
+++ b/sysutils/ledit/Makefile
@@ -7,15 +7,18 @@
#
PORTNAME= ledit
-PORTVERSION= 1.11
-PORTREVISION= 1
+PORTVERSION= 2.00
CATEGORIES= sysutils
-MASTER_SITES= ftp://ftp.inria.fr/INRIA/cristal/Daniel.de_Rauglaudre/Tools/ \
- http://home.leo.org/~barner/freebsd/distfiles/
+MASTER_SITES= http://cristal.inria.fr/~ddr/ledit/distrib/src/ \
+ http://pauillac.inria.fr/~ddr/ledit/distrib/src/
+EXTRACT_SUFX= .tgz
MAINTAINER= barner@FreeBSD.org
COMMENT= Line editor to be used with interactive commands
+BUILD_DEPENDS= camlp5r:${PORTSDIR}/devel/ocaml-camlp5
+
+USE_GMAKE= yes
USE_OCAML= yes
ALL_TARGET= all ledit.opt
@@ -23,9 +26,22 @@ ALL_TARGET= all ledit.opt
PLIST_FILES= bin/ledit
MAN1= ledit.1
+PORTDOCS= CHANGES LICENSE README
+
+.include <bsd.port.pre.mk>
+
+do-configure:
+ ${REINPLACE_CMD} -e '/^BINDIR=/s;/usr/local;${PREFIX};' \
+ -e '/^LIBDIR=/s;/usr/local;${PREFIX};' \
+ -e '/^MANDIR=/s;/usr/local;${PREFIX};' \
+ ${WRKSRC}/Makefile
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/ledit.out ${PREFIX}/bin/ledit
- ${INSTALL_MAN} ${WRKSRC}/ledit.l ${MANPREFIX}/man/man1/ledit.1
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/ledit/distinfo b/sysutils/ledit/distinfo
index 4957f05252eb..856dafb7c69e 100644
--- a/sysutils/ledit/distinfo
+++ b/sysutils/ledit/distinfo
@@ -1,3 +1,3 @@
-MD5 (ledit-1.11.tar.gz) = a2d38ba641682509c1e964ad699a9dd2
-SHA256 (ledit-1.11.tar.gz) = d5f3775e200f0bfcd2f255866b284572cb431b1befd61eab34112c10369c4d59
-SIZE (ledit-1.11.tar.gz) = 14027
+MD5 (ledit-2.00.tgz) = d5c21dc734e20ce13aa7b995621b1c9a
+SHA256 (ledit-2.00.tgz) = e6432682b8aa17d93c7c3be2316937e3ba48c9b6ca0789c47f864ee34d10a2fc
+SIZE (ledit-2.00.tgz) = 22598
diff --git a/sysutils/ledit/files/patch-pa_local.ml b/sysutils/ledit/files/patch-pa_local.ml
deleted file mode 100644
index 9c6f32e6e40a..000000000000
--- a/sysutils/ledit/files/patch-pa_local.ml
+++ /dev/null
@@ -1,15 +0,0 @@
---- pa_local.ml.orig Mon Jun 25 11:20:33 2007
-+++ pa_local.ml Mon Jun 25 11:21:06 2007
-@@ -14,10 +14,10 @@
- open Pcaml;
-
- value expr_of_patt p =
-- let loc = MLast.loc_of_patt p in
-+ let _loc = MLast.loc_of_patt p in
- match p with
- [ <:patt< $lid:x$ >> -> <:expr< $lid:x$ >>
-- | _ -> Stdpp.raise_with_loc loc (Stream.Error "identifier expected") ]
-+ | _ -> Stdpp.raise_with_loc _loc (Stream.Error "identifier expected") ]
- ;
-
- EXTEND
diff --git a/sysutils/ledit/pkg-descr b/sysutils/ledit/pkg-descr
index d8f4a5c43112..1ba6b9934a5e 100644
--- a/sysutils/ledit/pkg-descr
+++ b/sysutils/ledit/pkg-descr
@@ -1,3 +1,5 @@
Ledit is a line editor, allowing to use control commands like in emacs
or in shells (bash, tcsh). To be used with interactive commands. It is
-written in Ocaml and Camlp4 and uses the library unix.cma.
+written in Ocaml and Camlp5 and uses the library unix.cma.
+
+WWW: http://cristal.inria.fr/~ddr/ledit/