aboutsummaryrefslogtreecommitdiff
path: root/sysutils/lineakd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/lineakd/Makefile')
-rw-r--r--sysutils/lineakd/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/lineakd/Makefile b/sysutils/lineakd/Makefile
new file mode 100644
index 000000000000..3bb56f99078a
--- /dev/null
+++ b/sysutils/lineakd/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: lineakd
+# Date created: 03 June 2002
+# Whom: Kay Lehmann
+#
+# $FreeBSD$
+#
+
+PORTNAME= lineakd
+PORTVERSION= 0.4.p3
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=lineak
+DISTNAME= ${PORTNAME}-0.4pre3
+
+MAINTAINER= kay_lehmann@web.de
+COMMENT= Lineakd is a daemon which enables special keys on internet keyboards
+
+LIB_DEPENDS= intl.5:${PORTSDIR}/devel/gettext
+
+USE_BISON= yes
+USE_GMAKE= yes
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+
+CFLAGS+= -I${X11BASE}/include
+
+.include <bsd.port.pre.mk>
+
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-lineakd.c-4
+
+.if ${OSVERSION} >= 500000
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-lineakd.c-5
+.endif
+
+.include <bsd.port.post.mk>