aboutsummaryrefslogtreecommitdiff
path: root/sysutils/linneighborhood/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/linneighborhood/Makefile')
-rw-r--r--sysutils/linneighborhood/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/sysutils/linneighborhood/Makefile b/sysutils/linneighborhood/Makefile
index eae30b9a6956..8a410a93a898 100644
--- a/sysutils/linneighborhood/Makefile
+++ b/sysutils/linneighborhood/Makefile
@@ -24,6 +24,12 @@ USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502102
+FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
+.endif
+
post-patch:
${CP} ${FILESDIR}/mntent* ${WRKSRC}/src
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' ${WRKSRC}/configure
@@ -31,4 +37,4 @@ post-patch:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>