aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mcweject/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/mcweject/Makefile')
-rw-r--r--sysutils/mcweject/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/mcweject/Makefile b/sysutils/mcweject/Makefile
new file mode 100644
index 000000000000..6c543cffae3f
--- /dev/null
+++ b/sysutils/mcweject/Makefile
@@ -0,0 +1,43 @@
+# New ports collection Makefile for: mcweject
+# Date created: 11 Jan 2005
+# Whom: jbacon@mcw.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= mcweject
+PORTVERSION= 0.9
+CATEGORIES= sysutils
+MASTER_SITES= http://www.neuro.mcw.edu/~bacon/Ports/distfiles/
+
+MAINTAINER= jbacon@mcw.edu
+COMMENT= Removable media eject
+
+MAN1= eject.1
+MANCOMPRESSED= yes
+SUB_FILES= pkg-message
+
+CONFLICTS= eject-[0-9]*
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+PLIST_FILES= sbin/eject share/examples/mcweject/eject.allow
+PLIST_DIRS= share/examples/mcweject
+
+post-extract:
+.for f in eject eject.o eject.1.gz
+ ${RM} ${WRKSRC}/${f}
+.endfor
+
+do-install:
+ ${MKDIR} ${PREFIX}/share/examples/mcweject
+ ${INSTALL_DATA} ${WRKSRC}/eject.allow.sample \
+ ${PREFIX}/share/examples/mcweject/eject.allow
+ ${INSTALL_PROGRAM} ${WRKSRC}/eject ${PREFIX}/sbin
+ ${CHMOD} 4511 ${PREFIX}/sbin/eject
+ ${INSTALL_DATA} ${WRKSRC}/eject.1 ${PREFIX}/man/man1
+ ${GZIP_CMD} -best ${PREFIX}/man/man1/eject.1
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>