aboutsummaryrefslogtreecommitdiff
path: root/sysutils/megarc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/megarc/Makefile')
-rw-r--r--sysutils/megarc/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/sysutils/megarc/Makefile b/sysutils/megarc/Makefile
index 647070757d06..08b33b86cbcd 100644
--- a/sysutils/megarc/Makefile
+++ b/sysutils/megarc/Makefile
@@ -10,11 +10,14 @@ DISTNAME= dr_freebsd_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= LSI Logic's MegaRAID controlling software
+OPTIONS_DEFINE= DOCS
+
USES= dos2unix
USE_ZIP= yes
DOS2UNIX_GLOB= *.txt
NO_BUILD= yes
NO_WRKSUBDIR= yes
+STRIP=
ONLY_FOR_ARCHS= i386 amd64
RESTRICTED= Must be downloaded directly from the manufacturer
@@ -22,21 +25,18 @@ RESTRICTED= Must be downloaded directly from the manufacturer
PLIST_FILES= sbin/megarc
PORTDOCS= *
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
-IGNORE= has a distribution file that is not freely available. The binary is shipped on the Megaraid Universal Software Suite CD which accompanies any boxed LSI Logic RAID storage adaptor. Copy ${DISTNAME}${EXTRACT_SUFX} to ${DISTDIR} and try again. For further instructions, see http://www.freebsdwiki.net/index.php/Megarc
-.endif
-
post-extract:
@cd ${WRKSRC} && ${UNZIP_CMD} ${EXTRACT_BEFORE_ARGS} 'MegaRC 1.04.zip'
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/megarc ${PREFIX}/sbin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/Release\ History.txt ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/megarc ${STAGEDIR}${PREFIX}/sbin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Release\ History.txt ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= has a distribution file that is not freely available. The binary is shipped on the Megaraid Universal Software Suite CD which accompanies any boxed LSI Logic RAID storage adaptor. Copy ${DISTNAME}${EXTRACT_SUFX} to ${DISTDIR} and try again. For further instructions, see http://www.freebsdwiki.net/index.php/Megarc
.endif
.include <bsd.port.post.mk>