aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mktool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/mktool/Makefile')
-rw-r--r--sysutils/mktool/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/sysutils/mktool/Makefile b/sysutils/mktool/Makefile
new file mode 100644
index 000000000000..1e2d6c7f02bc
--- /dev/null
+++ b/sysutils/mktool/Makefile
@@ -0,0 +1,25 @@
+# ports collection makefile for: mktool
+# Date created: 2002/05/28
+# Whom: Jos Backus <jos@catnook.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mktool
+PORTVERSION= 0.0.7
+CATEGORIES= sysutils
+MASTER_SITES= http://www.io.com/~manoj/file/
+
+MAINTAINER= jos@catnook.com
+
+WRKSRC= ${WRKDIR}/mktool
+
+USE_GMAKE= yes
+
+post-extract:
+ @${PERL} -pi -e 's,^OPT=.*,OPT=${CFLAGS},; \
+ s,=gcc,?=gcc,; \
+ s,^bindir=.*,bindir=${PREFIX}/bin,; \
+ s,cp -a,install -m ${BINMODE},' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>