aboutsummaryrefslogtreecommitdiff
path: root/sysutils/mktool
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/mktool')
-rw-r--r--sysutils/mktool/Makefile25
-rw-r--r--sysutils/mktool/distinfo1
-rw-r--r--sysutils/mktool/pkg-comment1
-rw-r--r--sysutils/mktool/pkg-descr13
-rw-r--r--sysutils/mktool/pkg-plist7
5 files changed, 47 insertions, 0 deletions
diff --git a/sysutils/mktool/Makefile b/sysutils/mktool/Makefile
new file mode 100644
index 000000000000..1e2d6c7f02bc
--- /dev/null
+++ b/sysutils/mktool/Makefile
@@ -0,0 +1,25 @@
+# ports collection makefile for: mktool
+# Date created: 2002/05/28
+# Whom: Jos Backus <jos@catnook.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mktool
+PORTVERSION= 0.0.7
+CATEGORIES= sysutils
+MASTER_SITES= http://www.io.com/~manoj/file/
+
+MAINTAINER= jos@catnook.com
+
+WRKSRC= ${WRKDIR}/mktool
+
+USE_GMAKE= yes
+
+post-extract:
+ @${PERL} -pi -e 's,^OPT=.*,OPT=${CFLAGS},; \
+ s,=gcc,?=gcc,; \
+ s,^bindir=.*,bindir=${PREFIX}/bin,; \
+ s,cp -a,install -m ${BINMODE},' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/sysutils/mktool/distinfo b/sysutils/mktool/distinfo
new file mode 100644
index 000000000000..715d0a482821
--- /dev/null
+++ b/sysutils/mktool/distinfo
@@ -0,0 +1 @@
+MD5 (mktool-0.0.7.tar.gz) = cb2d4c919dca5c0a9e4fbf1a1b91d736
diff --git a/sysutils/mktool/pkg-comment b/sysutils/mktool/pkg-comment
new file mode 100644
index 000000000000..afb3be2f4478
--- /dev/null
+++ b/sysutils/mktool/pkg-comment
@@ -0,0 +1 @@
+Portable tools to manage processes and networked services
diff --git a/sysutils/mktool/pkg-descr b/sysutils/mktool/pkg-descr
new file mode 100644
index 000000000000..22e0fb717a4e
--- /dev/null
+++ b/sysutils/mktool/pkg-descr
@@ -0,0 +1,13 @@
+Tools to manage processes and networked services, modeled after Daniel
+Bernsteins daemontools and ucspi-tcp packages. The tools are written to be
+portable to a wide variety of platforms that support POSIX services.
+
+babysit Supervises a program, allowing it to started/stopped automatically
+bsok Check if a program is being babysat
+envuidgid Sets environment variables based on user, then runs a program
+setugid Sets uid and gid, then runs a program
+tcpaccept Accepts connections on stdin, then runs a program
+tcplisten Connects a network port to another program's stdin
+execlp Allows argv[0] to be set when running a program
+
+WWW: http://www.io.com/~manoj/file/
diff --git a/sysutils/mktool/pkg-plist b/sysutils/mktool/pkg-plist
new file mode 100644
index 000000000000..4465af419628
--- /dev/null
+++ b/sysutils/mktool/pkg-plist
@@ -0,0 +1,7 @@
+bin/babysit
+bin/bsok
+bin/envuidgid
+bin/execlp
+bin/setugid
+bin/tcpaccept
+bin/tcplisten