aboutsummaryrefslogtreecommitdiff
path: root/sysutils/msyslog/files
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/msyslog/files')
-rw-r--r--sysutils/msyslog/files/patch-configure54
-rw-r--r--sysutils/msyslog/files/patch-configure.in49
-rw-r--r--sysutils/msyslog/files/patch-im_tcp.c8
-rw-r--r--sysutils/msyslog/files/patch-src-config.h.in154
4 files changed, 212 insertions, 53 deletions
diff --git a/sysutils/msyslog/files/patch-configure b/sysutils/msyslog/files/patch-configure
new file mode 100644
index 000000000000..ba9bdf1a134c
--- /dev/null
+++ b/sysutils/msyslog/files/patch-configure
@@ -0,0 +1,54 @@
+--- configure.orig Sat Jan 4 15:45:31 2003
++++ configure Sat Jan 4 15:51:07 2003
+@@ -2941,7 +2941,7 @@
+ echo "$as_me:2941: result: $ac_cv_lib_dl_dlopen" >&5
+ echo "${ECHO_T}$ac_cv_lib_dl_dlopen" >&6
+ if test $ac_cv_lib_dl_dlopen = yes; then
+- SYSLOGD_LIBS="$SYSLOGD_LIBS -ldl"
++ SYSLOGD_LIBS="$SYSLOGD_LIBS"
+ fi
+
+ echo "$as_me:2947: checking for connect in -lsocket" >&5
+@@ -3573,9 +3573,9 @@
+ #define MSYSLOG_VERSION_STR "$MSYSLOG_VERSION"
+ EOF
+
+-echo msyslog version... $MSYSLOG_VERSION
++echo msyslog version... 1
+
+-MLIBNAME="libmsyslog.so.$MSYSLOG_VERSION" ;
++MLIBNAME="libmsyslog.so.1" ;
+ cat >>confdefs.h <<EOF
+ #define MLIBNAME_STR "$MLIBNAME"
+ EOF
+@@ -3644,14 +3644,6 @@
+ #define PID_DIR "$dir"
+ EOF
+
+-for MANDIR in "/usr/share/man" "/usr/man"
+-do
+- if test -d $MANDIR ; then
+- mandir=$MANDIR;
+- break;
+- fi
+-done
+-
+ echo "$as_me:3655: checking wether netdb.h requires _USE_IRS" >&5
+ echo $ECHO_N "checking wether netdb.h requires _USE_IRS... $ECHO_C" >&6
+ if grep _USE_IRS /usr/include/netdb.h >/dev/null ;then
+@@ -3736,6 +3728,15 @@
+
+ SHARED_PARAMS="-Bshareable"
+ DCCFLAGS="-fPIC"
++elif test "$UNAME" = "FreeBSD" ; then
++ cat >>confdefs.h <<\EOF
++#define DLOPEN_FLAGS RTLD_LAZY
++#define SYMBOL_PREFIX "_"
++EOF
++
++ SHARED_PARAMS="-Bshareable"
++ DCCFLAGS="-fPIC"
++ SYSLOGD_LIBS="$SYSLOGD_LIBS -Wl,-E"
+ elif test "$UNAME" = "Linux" ; then
+ cat >>confdefs.h <<\EOF
+ #define DLOPEN_FLAGS RTLD_LAZY | RTLD_GLOBAL
diff --git a/sysutils/msyslog/files/patch-configure.in b/sysutils/msyslog/files/patch-configure.in
deleted file mode 100644
index 18cda749877d..000000000000
--- a/sysutils/msyslog/files/patch-configure.in
+++ /dev/null
@@ -1,49 +0,0 @@
---- configure.in.orig Wed Nov 21 07:49:36 2001
-+++ configure.in Sun Mar 24 18:30:28 2002
-@@ -33,7 +33,7 @@
- AC_STRUCT_TM
-
- dnl Checks for library functions.
--AC_CHECK_LIB(dl, dlopen, SYSLOGD_LIBS="$SYSLOGD_LIBS -ldl")
-+AC_CHECK_LIB(c, dlopen)dnl
- AC_CHECK_LIB(socket, connect, SYSLOGD_LIBS="$SYSLOGD_LIBS -lsocket")
- AC_CHECK_LIB(nsl, gethostbyname, SYSLOGD_LIBS="$SYSLOGD_LIBS -lnsl")
- AC_DEFINE(SYSLOGD_LIBS, $SYSLOGD_LIBS)
-@@ -65,7 +65,7 @@
- AC_DEFINE_UNQUOTED(MSYSLOG_VERSION_STR, "$MSYSLOG_VERSION")
- echo msyslog version... $MSYSLOG_VERSION
-
--MLIBNAME="libmsyslog.so.$MSYSLOG_VERSION" ;
-+MLIBNAME="libmsyslog.so.1" ;
- AC_DEFINE_UNQUOTED(MLIBNAME_STR, "$MLIBNAME")
-
- MANPAGES="syslog.conf.5 syslogd.8"
-@@ -93,14 +93,7 @@
- AC_MSG_RESULT(root-mode pid file will go in $dir)
- AC_DEFINE_UNQUOTED(PID_DIR, "$dir")
-
--dnl search mandir for non bsd systems
--for MANDIR in "/usr/share/man" "/usr/man"
--do
-- if test -d $MANDIR ; then
-- mandir=$MANDIR;
-- break;
-- fi
--done
-+AC_DEFINE_UNQUOTED(MANDIR, "$prefix/man")
-
- dnl Check underscore requirement for dlsym()
-
-@@ -150,6 +143,12 @@
- AC_DEFINE_UNQUOTED(SYMBOL_PREFIX, "_")
- SHARED_PARAMS="-Bshareable"
- DCCFLAGS="-fPIC"
-+elif test "$UNAME" = "FreeBSD" ; then
-+ AC_DEFINE(DLOPEN_FLAGS, RTLD_LAZY)dnl
-+ AC_DEFINE_UNQUOTED(SYMBOL_PREFIX, "")dnl
-+ SHARED_PARAMS="-Bshareable"
-+ DCCFLAGS="-fPIC"
-+ SYSLOGD_LIBS="$SYSLOGD_LIBS -Wl,-E"
- elif test "$UNAME" = "Linux" ; then
- AC_DEFINE(DLOPEN_FLAGS, RTLD_LAZY | RTLD_GLOBAL)
- AC_DEFINE_UNQUOTED(SYMBOL_PREFIX, "")
diff --git a/sysutils/msyslog/files/patch-im_tcp.c b/sysutils/msyslog/files/patch-im_tcp.c
index a59664539cfa..d75e48cb2a80 100644
--- a/sysutils/msyslog/files/patch-im_tcp.c
+++ b/sysutils/msyslog/files/patch-im_tcp.c
@@ -1,14 +1,14 @@
---- src/modules/im_tcp.c.orig Thu Jun 14 07:30:35 2001
-+++ src/modules/im_tcp.c Sun Jul 1 03:34:58 2001
+--- src/modules/im_tcp.c.orig Sat Jan 4 15:42:05 2003
++++ src/modules/im_tcp.c Sat Jan 4 15:42:41 2003
@@ -61,6 +61,7 @@
#include <sys/types.h>
#include <sys/socket.h>
#include <sys/uio.h>
+#include <sys/param.h>
+ #include <ctype.h>
#include <stdlib.h>
#include <unistd.h>
- #include <errno.h>
-@@ -71,11 +72,6 @@
+@@ -72,11 +73,6 @@
#include "../modules.h"
#include "../syslogd.h"
diff --git a/sysutils/msyslog/files/patch-src-config.h.in b/sysutils/msyslog/files/patch-src-config.h.in
new file mode 100644
index 000000000000..1bd54f043981
--- /dev/null
+++ b/sysutils/msyslog/files/patch-src-config.h.in
@@ -0,0 +1,154 @@
+--- src/config.h.in.orig Sat Jan 4 20:23:08 2003
++++ src/config.h.in Sat Jan 4 20:22:53 2003
+@@ -0,0 +1,151 @@
++/* config.h.in. Generated automatically from configure.in by autoheader. */
++
++/* Define to empty if the keyword does not work. */
++#undef const
++
++/* Define if you don't have vprintf but do have _doprnt. */
++#undef HAVE_DOPRNT
++
++/* Define if you have the vprintf function. */
++#undef HAVE_VPRINTF
++
++/* Define to `long' if <sys/types.h> doesn't define. */
++#undef off_t
++
++/* Define as the return type of signal handlers (int or void). */
++#undef RETSIGTYPE
++
++/* Define to `unsigned' if <sys/types.h> doesn't define. */
++#undef size_t
++
++/* Define if you have the ANSI C header files. */
++#undef STDC_HEADERS
++
++/* Define if you can safely include both <sys/time.h> and <time.h>. */
++#undef TIME_WITH_SYS_TIME
++
++/* Define if your <sys/time.h> declares struct tm. */
++#undef TM_IN_SYS_TIME
++
++/* Define if you have the gethostname function. */
++#undef HAVE_GETHOSTNAME
++
++/* Define if you have the regcomp function. */
++#undef HAVE_REGCOMP
++
++/* Define if you have the select function. */
++#undef HAVE_POLL
++
++/* Define if you have the select function. */
++#undef HAVE_SELECT
++
++/* Define if you have the socket function. */
++#undef HAVE_SOCKET
++
++/* Define if you have the strdup function. */
++#undef HAVE_STRDUP
++
++/* Define if you have the strerror function. */
++#undef HAVE_STRERROR
++
++/* Define if you have the strstr function. */
++#undef HAVE_STRSTR
++
++/* Define if you have the strtoul function. */
++#undef HAVE_STRTOUL
++
++/* Define if you have the <dirent.h> header file. */
++#undef HAVE_DIRENT_H
++
++/* Define if you have the <fcntl.h> header file. */
++#undef HAVE_FCNTL_H
++
++/* Define if you have the <limits.h> header file. */
++#undef HAVE_LIMITS_H
++
++/* Define if you have the <ndir.h> header file. */
++#undef HAVE_NDIR_H
++
++/* Define if you have the <paths.h> header file. */
++#undef HAVE_PATHS_H
++
++/* Define if you have the <strings.h> header file. */
++#undef HAVE_STRINGS_H
++
++/* Define if you have the <sys/dir.h> header file. */
++#undef HAVE_SYS_DIR_H
++
++/* Define if you have the <sys/ioctl.h> header file. */
++#undef HAVE_SYS_IOCTL_H
++
++/* Define if you have the <sys/ndir.h> header file. */
++#undef HAVE_SYS_NDIR_H
++
++/* Define if you have the <sys/time.h> header file. */
++#undef HAVE_SYS_TIME_H
++
++/* Define if you have the <syslog.h> header file. */
++#undef HAVE_SYSLOG_H
++
++/* Define if you have the <unistd.h> header file. */
++#undef HAVE_UNISTD_H
++
++#undef HAVE_SYSCTL_H
++#undef HAVE_ERR_H
++
++#undef MSYSLOG_VERSION_STR
++#undef MLIBNAME_STR
++#undef INSTALL_LIBDIR
++#undef PID_DIR
++#undef PID_FILE
++
++#undef HAVE_OPTRESET
++
++#undef DLOPEN_FLAGS
++#undef SYMBOL_PREFIX
++
++#undef HAVE_SRANDOM
++#undef HAVE_MD5
++#undef HAVE_SHA1
++#undef HAVE_RMD160
++
++#undef HAVE_SOCKLEN_T
++#undef HAVE_UINT32_T
++#undef HAVE_UINT64_T
++#undef HAVE_U_INT32_T
++#undef HAVE___UINT32_T
++#undef HAVE_U_INT64_T
++#undef HAVE___UINT64_T
++
++#undef HAVE_CODE
++
++#undef MLIBNAME
++
++#undef HAVE_SYS_WAIT_H
++
++#undef HAVE_GETADDRINFO
++
++#undef HAVE_INET_NTOP
++
++#undef HAVE_STREAMS_IMODULE
++#undef HAVE_LINUX_IMODULE
++#undef HAVE_BSD_IMODULE
++#undef HAVE_UNIX_IMODULE
++
++#undef HAVE_SOCKADDR_SA_LEN
++
++#undef _USE_IRS
++#undef SIGALTSTACK_WITH_STACK_T
++#undef HAVE_SYS_CONTEXT_H
++
++#undef NEEDS_DLOPEN_NULL
++
++#undef _SGIAPI
++#undef INET6
++
++#undef WORDS_BIGENDIAN
++
++#undef _GNU_SOURCE
++
++/* for Solaris */
++#undef _REENTRANT