aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nut22/files
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/nut22/files')
-rw-r--r--sysutils/nut22/files/nut.sh.in44
-rw-r--r--sysutils/nut22/files/nut_upslog.sh.in36
-rw-r--r--sysutils/nut22/files/nut_upsmon.sh.in34
-rw-r--r--sysutils/nut22/files/patch-Makefile.in33
-rw-r--r--sysutils/nut22/files/patch-drivers_Makefile.in11
5 files changed, 0 insertions, 158 deletions
diff --git a/sysutils/nut22/files/nut.sh.in b/sysutils/nut22/files/nut.sh.in
deleted file mode 100644
index 9cd40c1430b5..000000000000
--- a/sysutils/nut22/files/nut.sh.in
+++ /dev/null
@@ -1,44 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: nut
-# REQUIRE: NETWORKING
-# BEFORE: LOGIN
-# KEYWORD: shutdown
-
-# Define these nut_* variables in one of these files:
-# /etc/rc.conf
-# /etc/rc.conf.local
-# /etc/rc.conf.d/nut
-#
-# DO NOT CHANGE THESE DEFAULT VALUES HERE
-#
-nut_enable=${nut_enable-"NO"}
-nut_prefix=${nut_prefix-"%%PREFIX%%"}
-
-. %%RC_SUBR%%
-
-name="nut"
-rcvar=`set_rcvar`
-
-load_rc_config $name
-
-required_dirs="%%STATEDIR%%"
-required_files="${nut_prefix}/etc/nut/ups.conf ${nut_prefix}/etc/nut/upsd.conf ${nut_prefix}/etc/nut/upsd.users"
-command="${nut_prefix}/sbin/upsd"
-pidfile="%%STATEDIR%%/upsd.pid"
-
-start_precmd="nut_prestart"
-stop_postcmd="nut_poststop"
-
-nut_prestart() {
- ${nut_prefix}/libexec/nut/upsdrvctl start
-}
-
-nut_poststop() {
- ${nut_prefix}/libexec/nut/upsdrvctl stop
-}
-
-run_rc_command "$1"
diff --git a/sysutils/nut22/files/nut_upslog.sh.in b/sysutils/nut22/files/nut_upslog.sh.in
deleted file mode 100644
index 908451b9c331..000000000000
--- a/sysutils/nut22/files/nut_upslog.sh.in
+++ /dev/null
@@ -1,36 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: nut_upslog
-# REQUIRE: NETWORKING nut
-# BEFORE: LOGIN
-# KEYWORD: shutdown
-
-# Define these nut_upslog* variables in one of these files:
-# /etc/rc.conf
-# /etc/rc.conf.local
-# /etc/rc.conf.d/nut_upslog
-#
-# DO NOT CHANGE THESE DEFAULT VALUES HERE
-#
-nut_upslog_enable=${nut_upslog_enable-"NO"}
-nut_upslog_prefix=${nut_upslog_prefix-"%%PREFIX%%"}
-nut_upslog_logfile=${nut_upslog_logfile-"/var/log/ups.log"}
-nut_upslog_interval=${nut_upslog_interval-"300"}
-nut_upslog_ups=${nut_upslog_ups-"myups@localhost"}
-
-. %%RC_SUBR%%
-
-name="nut_upslog"
-rcvar=`set_rcvar`
-
-load_rc_config $name
-
-required_dirs="%%STATEDIR%%"
-command="${nut_upslog_prefix}/bin/upslog"
-pidfile="%%STATEDIR%%/upslog.pid"
-nut_upslog_flags=${nut_upslog_flags-"-s ${nut_upslog_ups} -l ${nut_upslog_logfile} -i ${nut_upslog_interval}"}
-
-run_rc_command "$1"
diff --git a/sysutils/nut22/files/nut_upsmon.sh.in b/sysutils/nut22/files/nut_upsmon.sh.in
deleted file mode 100644
index 5d5449dc3204..000000000000
--- a/sysutils/nut22/files/nut_upsmon.sh.in
+++ /dev/null
@@ -1,34 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: nut_upsmon
-# REQUIRE: NETWORKING nut
-# BEFORE: LOGIN
-# KEYWORD: shutdown
-
-# Define these nut_upsmon* variables in one of these files:
-# /etc/rc.conf
-# /etc/rc.conf.local
-# /etc/rc.conf.d/nut_upsmon
-#
-# DO NOT CHANGE THESE DEFAULT VALUES HERE
-#
-nut_upsmon_enable=${nut_upsmon_enable-"NO"}
-nut_upsmon_prefix=${nut_upsmon_prefix-"%%PREFIX%%"}
-
-. %%RC_SUBR%%
-
-name="nut_upsmon"
-rcvar=`set_rcvar`
-
-load_rc_config $name
-
-required_dirs="%%STATEDIR%%"
-required_files="${nut_upsmon_prefix}/etc/nut/upsmon.conf"
-command="${nut_upsmon_prefix}/sbin/upsmon"
-pidfile="%%STATEDIR%%/upsmon.pid"
-nut_upsmon_flags=${nut_upsmon_flags-"localhost"}
-
-run_rc_command "$1"
diff --git a/sysutils/nut22/files/patch-Makefile.in b/sysutils/nut22/files/patch-Makefile.in
deleted file mode 100644
index 72832e15e229..000000000000
--- a/sysutils/nut22/files/patch-Makefile.in
+++ /dev/null
@@ -1,33 +0,0 @@
---- Makefile.in.orig Mon Oct 10 04:12:51 2005
-+++ Makefile.in Thu Feb 23 19:44:12 2006
-@@ -90,6 +90,12 @@
- install-cgi-conf:
- @cd conf; $(MAKE) install-cgi-conf; cd ..;
-
-+lib: build-lib
-+
-+build-lib:
-+ @cd common ; $(MAKE) || exit 1; cd ..;
-+ @cd clients; $(MAKE) libupsclient.a || exit 1; cd ..;
-+
- install-lib:
- @cd clients; $(MAKE) install-lib; cd ..;
- @cd man; $(MAKE) install-lib-man; cd ..;
-@@ -98,6 +104,7 @@
- usb: build-usb
-
- build-usb:
-+ @cd common ; $(MAKE) || exit 1; cd ..;
- @cd drivers; $(MAKE) build-usb; cd ..;
-
- install-usb:
-@@ -107,7 +114,8 @@
- snmp: build-snmp
-
- build-snmp:
-- @cd drivers; $(MAKE) snmp-ups; cd ..;
-+ @cd common ; $(MAKE) || exit 1; cd ..;
-+ @cd drivers; $(MAKE) snmp-ups || exit 1; cd ..;
-
- install-snmp: snmp install-snmp-man install-snmp-mgr
-
diff --git a/sysutils/nut22/files/patch-drivers_Makefile.in b/sysutils/nut22/files/patch-drivers_Makefile.in
deleted file mode 100644
index 5ef287b7ee51..000000000000
--- a/sysutils/nut22/files/patch-drivers_Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- drivers/Makefile.in.orig Thu Feb 23 19:38:14 2006
-+++ drivers/Makefile.in Thu Feb 23 19:38:43 2006
-@@ -8,7 +8,7 @@
-
- # other definitions
- CC = @CC@
--CFLAGS = -I../include @CFLAGS@
-+CFLAGS = -I../include @CFLAGS@ @LIBUSB_CFLAGS@
- PROGS = bestups fentonups apcsmart everups belkin masterguard powercom \
- cyberpower tripplite victronups genericups mge-utalk bestuferrups \
- isbmex etapro liebert sms esupssmart tripplitesu blazer safenet \