aboutsummaryrefslogtreecommitdiff
path: root/sysutils/nvtv
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/nvtv')
-rw-r--r--sysutils/nvtv/Makefile35
-rw-r--r--sysutils/nvtv/distinfo2
-rw-r--r--sysutils/nvtv/pkg-descr6
3 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/nvtv/Makefile b/sysutils/nvtv/Makefile
new file mode 100644
index 000000000000..db23029e6ec3
--- /dev/null
+++ b/sysutils/nvtv/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: nv-tv-out
+# Date Created: 19 May 2004
+# Whom: Samuel Tardieu <sam@rfc1149.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nvtv
+PORTVERSION= 0.4.7
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= nv-tv-out
+DISTNAME= nvtv-${PORTVERSION}
+
+MAINTAINER= sam@rfc1149.net
+COMMENT= TV output on nvidia card
+
+LIB_DEPENDS= pci.2:${PORTSDIR}/devel/libpci
+
+CONFIGURE_ENV= CC="${CC} -I${PREFIX}/include"
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+USE_LIBTOOL_VER= 15
+USE_GETOPT_LONG= yes
+USE_GNOME= gtk12
+USE_REINPLACE= yes
+
+MAN1= nvtv.1x
+MAN8= nvtvd.8
+PLIST_FILES= bin/nvtv bin/nvtvd
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lgnugetopt||g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/sysutils/nvtv/distinfo b/sysutils/nvtv/distinfo
new file mode 100644
index 000000000000..d5e3ac0c50cc
--- /dev/null
+++ b/sysutils/nvtv/distinfo
@@ -0,0 +1,2 @@
+MD5 (nvtv-0.4.7.tar.gz) = 35348d7608f94b7d114cd6ef46b66fc7
+SIZE (nvtv-0.4.7.tar.gz) = 419564
diff --git a/sysutils/nvtv/pkg-descr b/sysutils/nvtv/pkg-descr
new file mode 100644
index 000000000000..2917ac8699ec
--- /dev/null
+++ b/sysutils/nvtv/pkg-descr
@@ -0,0 +1,6 @@
+This tool enables TV-Out for NVidia cards. It does not need the kernel,
+supports multiple TV encoder chips. You may use all the features of the
+chip, down to direct register access, and all resolutions and sizes the
+chip supports.
+
+WWW: http://sourceforge.net/projects/nv-tv-out/