aboutsummaryrefslogtreecommitdiff
path: root/sysutils/p5-Schedule-At
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/p5-Schedule-At')
-rw-r--r--sysutils/p5-Schedule-At/Makefile2
-rw-r--r--sysutils/p5-Schedule-At/files/patch-At.pm2
2 files changed, 2 insertions, 2 deletions
diff --git a/sysutils/p5-Schedule-At/Makefile b/sysutils/p5-Schedule-At/Makefile
index 59fe4efbdc5d..3da71da2b445 100644
--- a/sysutils/p5-Schedule-At/Makefile
+++ b/sysutils/p5-Schedule-At/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Schedule-At
PORTVERSION= 1.03
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Schedule
diff --git a/sysutils/p5-Schedule-At/files/patch-At.pm b/sysutils/p5-Schedule-At/files/patch-At.pm
index 64ca9761c716..e0031ed112f2 100644
--- a/sysutils/p5-Schedule-At/files/patch-At.pm
+++ b/sysutils/p5-Schedule-At/files/patch-At.pm
@@ -33,7 +33,7 @@
+ $AT{'parseJobList'} =
+ sub {
+ my @a = split(/\s+/, $_[0]);
-+ if (/^\d\d/) {
++ if ($_[0] =~ /^\d\d/) {
+ return ($a[4], "$a[0] $a[1]");
+ } elsif (defined $a[8]) {
+ return ($a[8], "$a[0] $a[1] $a[2] $a[3] $a[4] $a[5]");