aboutsummaryrefslogtreecommitdiff
path: root/sysutils/p5-Sys-Gamin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/p5-Sys-Gamin/Makefile')
-rw-r--r--sysutils/p5-Sys-Gamin/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/sysutils/p5-Sys-Gamin/Makefile b/sysutils/p5-Sys-Gamin/Makefile
new file mode 100644
index 000000000000..4571e261c58c
--- /dev/null
+++ b/sysutils/p5-Sys-Gamin/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Sys-Gamin
+# Date created: 03 May 2007
+# Whom: Nick Hibma <n_hibma@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Sys-Gamin
+PORTVERSION= 0.1
+CATEGORIES= sysutils perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Sys
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= n_hibma@freebsd.org
+COMMENT= Perl interface to Gamin (File Access Monitor implementation)
+
+PERL_CONFIGURE= yes
+USE_FAM= yes
+MAN1= monitor.1
+MAN3= Sys::Gamin.3
+
+pre-configure:
+ ${PERL} -pi -e 'm/LIBS =>/ && print " INC => \"-I${LOCALBASE}/include\",\n"' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>