aboutsummaryrefslogtreecommitdiff
path: root/sysutils/password-store/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/password-store/Makefile')
-rw-r--r--sysutils/password-store/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/sysutils/password-store/Makefile b/sysutils/password-store/Makefile
index 1bc152cac777..4077d23f3e29 100644
--- a/sysutils/password-store/Makefile
+++ b/sysutils/password-store/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= password-store
-PORTVERSION= 1.6.3
-PORTREVISION= 2
+PORTVERSION= 1.6.5
CATEGORIES= sysutils
MASTER_SITES= http://git.zx2c4.com/password-store/snapshot/
@@ -22,6 +21,7 @@ NO_ARCH= yes
NO_BUILD= yes
OPTIONS_DEFINE= GIT XCLIP CONTRIB DOCS EXAMPLES
+OPTIONS_DEFAULT= CONTRIB
OPTIONS_SUB= yes
GIT_DESC= Enable git storage
@@ -34,26 +34,24 @@ XCLIP_RUN_DEPENDS= base64>=0:converters/base64 \
.include <bsd.port.options.mk>
-.if ! ${PORT_OPTIONS:MGIT} && ! ${PORT_OPTIONS:MXCLIP}
-EXTRA_PATCHES= ${PATCHDIR}/git+xclip.patch:-p1
-.elif ! ${PORT_OPTIONS:MGIT}
-EXTRA_PATCHES= ${PATCHDIR}/git.patch:-p1
-.elif ! ${PORT_OPTIONS:MXCLIP}
-EXTRA_PATCHES= ${PATCHDIR}/xclip.patch:-p1
-.endif
-
post-patch:
@${REINPLACE_CMD} -Ee 's|GETOPT="getopt"|GETOPT="${LOCALBASE}/bin/getopt"|' ${WRKSRC}/src/password-store.sh
@${REINPLACE_CMD} -Ee 's|SHRED="shred -f -z"|SHRED="rm -P -f"|' ${WRKSRC}/src/password-store.sh
do-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/src/password-store.sh ${STAGEDIR}${PREFIX}/libexec/pass
- @${LN} -s ${PREFIX}/libexec/pass ${STAGEDIR}${PREFIX}/bin/pass
+ ${INSTALL_SCRIPT} ${WRKSRC}/src/password-store.sh ${STAGEDIR}${PREFIX}/libexec/pass
+ ${LN} -s ${PREFIX}/libexec/pass ${STAGEDIR}${PREFIX}/bin/pass
do-install-CONTRIB-on:
@${MKDIR} ${STAGEDIR}${DATADIR}
- @(cd ${WRKSRC}/contrib && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
- @(cd ${WRKSRC}/src/completion && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
+ (cd ${WRKSRC}/contrib && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
+ (cd ${WRKSRC}/src/completion && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/zsh/site-functions
+ ${INSTALL_DATA} ${STAGEDIR}${DATADIR}/pass.zsh-completion ${STAGEDIR}${PREFIX}/share/zsh/site-functions/_pass
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d
+ ${INSTALL_DATA} ${STAGEDIR}${DATADIR}/pass.bash-completion ${STAGEDIR}${PREFIX}/etc/bash_completion.d/password-store
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/fish/completions
+ ${INSTALL_DATA} ${STAGEDIR}${DATADIR}/pass.fish-completion ${STAGEDIR}${PREFIX}/share/fish/completions/password-store.fish
do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}