aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pdumpfs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/pdumpfs/Makefile')
-rw-r--r--sysutils/pdumpfs/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/pdumpfs/Makefile b/sysutils/pdumpfs/Makefile
new file mode 100644
index 000000000000..7ebe620307db
--- /dev/null
+++ b/sysutils/pdumpfs/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: pdumpfs
+# Date created: 30 April 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pdumpfs
+PORTVERSION= 0.3
+CATEGORIES= sysutils
+MASTER_SITES= http://namazu.org/~satoru/pdumpfs/
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+
+RUBY_SHEBANG_FILES= ${WRKSRC}/pdumpfs
+DOCS_EN= ChangeLog pdumpfs-en.html
+DOCS_JA= pdumpfs-ja.html
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pdumpfs ${PREFIX}/sbin/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/${PORTNAME}/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${f} ${PREFIX}/share/doc/${PORTNAME}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>