aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pear-File/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/pear-File/Makefile')
-rw-r--r--sysutils/pear-File/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/sysutils/pear-File/Makefile b/sysutils/pear-File/Makefile
index 73117c086602..ec6b664c8b5c 100644
--- a/sysutils/pear-File/Makefile
+++ b/sysutils/pear-File/Makefile
@@ -7,6 +7,7 @@
PORTNAME= File
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= sysutils www
MASTER_SITES= http://pear.php.net/get/
PKGNAMEPREFIX= pear-
@@ -16,8 +17,8 @@ DIST_SUBDIR= PEAR
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR common file and directory routines
-BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
-RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php.dist:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
NO_BUILD= yes
@@ -25,14 +26,21 @@ NO_BUILD= yes
.if exists(${LOCALBASE}/bin/php-config)
PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.else
+PHP_BASE!= ${LOCALBASE}
.endif
+PEAR= ${LOCALBASE}/bin/pear
LPHP_LIB= lib/php
PEARDIR= ${PHP_BASE}/${LPHP_LIB}
PLIST_SUB= PEARDIR=${LPHP_LIB}
do-install:
@${CP} -Rp ${WRKSRC}/* ${PEARDIR}
- @${CHOWN} -R root:wheel ${PEARDIR}/${PORTNAME}*
- @${CHOWN} -R root:wheel ${PEARDIR}/tests
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/${PORTNAME}*
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/tests
+
+post-install:
+# Register a new package
+ @${PEAR} install -r -f ${WRKDIR}/package.xml
.include <bsd.port.post.mk>