aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pipemeter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/pipemeter/Makefile')
-rw-r--r--sysutils/pipemeter/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/sysutils/pipemeter/Makefile b/sysutils/pipemeter/Makefile
index b76908e311c1..7a7892dc78ab 100644
--- a/sysutils/pipemeter/Makefile
+++ b/sysutils/pipemeter/Makefile
@@ -1,32 +1,29 @@
# New ports collection makefile for: pipemeter
-# Date created: 2003-12-02
-# Whom: Len Sassaman
+# Date created: 2003-12-02
+# Whom: Len Sassama
#
# $FreeBSD$
#
PORTNAME= pipemeter
-PORTVERSION= 0.9.1
+PORTVERSION= 1.0.0
CATEGORIES= sysutils
MASTER_SITES= http://ports.abditum.com/pipemeter/ \
http://spamaps.org/files/pipemeter/
MAINTAINER= rabbi@abditum.com
-COMMENT= Measure speed of data going through a pipe
+COMMENT= A tool for displaying pipe status information
+USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+WRKSRC= ${WRKDIR}/${DISTNAME}
+CONFIGURE_ENV= PREFIX="${PREFIX}"
MAN1= pipemeter.1
-PORTDOCS= Changelog README
PLIST_FILES= bin/pipemeter
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/pipemeter ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/pipemeter.1 ${MAN1PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/pipemeter ${PREFIX}/bin/pipemeter
+ ${INSTALL_MAN} ${WRKSRC}/pipemeter.1 ${PREFIX}/man/man1/pipemeter.1
.include <bsd.port.mk>