aboutsummaryrefslogtreecommitdiff
path: root/sysutils/pmap/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/pmap/Makefile')
-rw-r--r--sysutils/pmap/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/sysutils/pmap/Makefile b/sysutils/pmap/Makefile
index 294c524a1802..e3b2d84d49ac 100644
--- a/sysutils/pmap/Makefile
+++ b/sysutils/pmap/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= ftp://ftp.wuppy.net.ru/pub/FreeBSD/local/pmap/
MAINTAINER= skv@FreeBSD.org
COMMENT= Detailed process memory display
+NO_PACKAGE= Depends on kernel
+
PLIST_SUB= KMODDIR=${KMODDIR}
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -29,4 +31,12 @@ BROKEN= "Currently does not support -CURRENT"
IGNORE= "Not supported on systems prior to 4.5"
.endif
+pre-fetch:
+.if !exists(${SRC_BASE}/sys/Makefile)
+IGNORE= "This port requires kernel sources"
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
.include <bsd.port.post.mk>