aboutsummaryrefslogtreecommitdiff
path: root/sysutils/polkit-gnome/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/polkit-gnome/Makefile')
-rw-r--r--sysutils/polkit-gnome/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/sysutils/polkit-gnome/Makefile b/sysutils/polkit-gnome/Makefile
new file mode 100644
index 000000000000..0b525ec44a54
--- /dev/null
+++ b/sysutils/polkit-gnome/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: polkit-gnome
+# Date Created: 30 Juli 2009
+# Whom: Koop Mast<kwm@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/sysutils/polkit-gnome/Makefile,v 1.5 2009/11/24 02:22:19 marcus Exp $
+#
+
+PORTNAME= polkit-gnome
+PORTVERSION= 0.95
+CATEGORIES= sysutils gnome
+MASTER_SITES= http://hal.freedesktop.org/releases/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME frontend to the PolicKit framework
+
+BUILD_DEPENDS= ${LOCALBASE}/share/gir-1.0/Gtk-2.0.gir:${PORTSDIR}/x11-toolkits/gir-repository-gtk20
+LIB_DEPENDS= polkit-gobject-1.0:${PORTSDIR}/sysutils/polkit
+RUN_DEPENDS= ${LOCALBASE}/share/gir-1.0/Gtk-2.0.gir:${PORTSDIR}/x11-toolkits/gir-repository-gtk20
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_GNOME= gnomehack gnomeprefix gtk20 intlhack
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= --disable-gtk-doc \
+ --localstatedir=/var
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>