aboutsummaryrefslogtreecommitdiff
path: root/sysutils/puppet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/puppet/Makefile')
-rw-r--r--sysutils/puppet/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/sysutils/puppet/Makefile b/sysutils/puppet/Makefile
new file mode 100644
index 000000000000..61675e4ea80a
--- /dev/null
+++ b/sysutils/puppet/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: rubygem-puppet
+# Date created: 2007-03-03
+# Whom: Tomoyuki Sakurai <cherry@trombik.mine.nu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= puppet
+PORTVERSION= 0.22.1
+CATEGORIES= sysutils
+MASTER_SITES= http://www.reductivelabs.com/downloads/puppet/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= cherry@trombik.org
+COMMENT= A configuration management framework written in Ruby
+
+BUILD_DEPENDS= ${RUBY_SITELIBDIR}/facter.rb:${PORTSDIR}/sysutils/facter
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+NO_BUILD= yes
+USE_RUBY= yes
+
+DOCS= CHANGELOG TODO README LICENSE COPYING
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ cd ${WRKSRC} && \
+ ${SETENV} DSTDIR=${DSTDIR}/${PREFIX} \
+ ${RUBY} ${WRKSRC}/install.rb --full
+ ${INSTALL} -d ${DOCSDIR}
+.if !defined(NOPORTDOCS)
+.for FILE in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+ ${INSTALL} -d ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ @${CHOWN} -R root:wheel ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>