aboutsummaryrefslogtreecommitdiff
path: root/sysutils/screen/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/screen/Makefile')
-rw-r--r--sysutils/screen/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/sysutils/screen/Makefile b/sysutils/screen/Makefile
index 7c950e9030fe..10b1cc137cb2 100644
--- a/sysutils/screen/Makefile
+++ b/sysutils/screen/Makefile
@@ -1,4 +1,4 @@
-# Created by: ache
+# Created by: Andrey Chernov <ache@FreeBSD.org>
# $FreeBSD$
PORTNAME= screen
@@ -8,11 +8,10 @@ CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.uni-erlangen.de/pub/utilities/screen/ \
http://komquats.com/distfiles/ \
http://people.freebsd.org/~cy/distfiles/ \
- ${MASTER_SITE_GNU}
-MASTER_SITE_SUBDIR= screen
+ GNU
MAINTAINER= cy@FreeBSD.org
-COMMENT= A multi-screen window manager
+COMMENT= Multi-screen window manager
OPTIONS_DEFINE= CJK INFO MAN NETHACK XTERM_256 HOSTINLOCKED SHOWENC
OPTIONS_DEFAULT= INFO MAN NETHACK XTERM_256
@@ -40,10 +39,6 @@ INFO= screen
MAKE_ARGS+= -DWITH_INFO
.endif
-.if ${ARCH} == "alpha"
-CFLAGS+= -O0
-.endif
-
# Enables support for 256 colour xterm. Note that you may need to
# set up a custom termcap entry or .screenrc which modifies termcap
# to contain the following: Co#256:AB=\E[48;5;%dm:AF=\E[38;5;%dm
@@ -76,7 +71,7 @@ post-patch:
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/etc/etcscreenrc ${STAGEDIR}${EXAMPLESDIR}/screenrc
-
+ ${INSTALL_DATA} ${WRKSRC}/etc/etcscreenrc \
+ ${STAGEDIR}${EXAMPLESDIR}/screenrc
.include <bsd.port.mk>