aboutsummaryrefslogtreecommitdiff
path: root/sysutils/sweeper/files/patch-ark-CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/sweeper/files/patch-ark-CMakeLists.txt')
-rw-r--r--sysutils/sweeper/files/patch-ark-CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/sysutils/sweeper/files/patch-ark-CMakeLists.txt b/sysutils/sweeper/files/patch-ark-CMakeLists.txt
new file mode 100644
index 000000000000..fae223ae2a40
--- /dev/null
+++ b/sysutils/sweeper/files/patch-ark-CMakeLists.txt
@@ -0,0 +1,26 @@
+KDE SVN revision r1230915.
+
+Author: rkcosta (Raphael Kubo da Costa)
+Date: Sun May 8 17:30:06 2011 +0000
+
+ Put the libarchive detection calls before configure_file().
+
+ The generated config.h was using some variables defined only after
+ plugins/CMakeLists.txt called macro_optional_find_package(LibArchive),
+ however the top-level CMakeLists.txt relied on these variables already
+ being set, which was never the case.
+
+ BUG: 271553
+ FIXED-IN: 4.6.4
+
+--- ark/CMakeLists.txt
++++ ark/CMakeLists.txt
+@@ -1,5 +1,8 @@
+ project(ark)
+
++macro_optional_find_package(LibArchive)
++macro_log_feature(LIBARCHIVE_FOUND "LibArchive" "A library for dealing with a wide variety of archive file formats" "http://code.google.com/p/libarchive/" FALSE "" "Required for among others tar, tar.gz, tar.bz2 formats in Ark.")
++
+ configure_file(config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h)
+
+ add_subdirectory(part)