aboutsummaryrefslogtreecommitdiff
path: root/sysutils/thefish/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/thefish/Makefile')
-rw-r--r--sysutils/thefish/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/sysutils/thefish/Makefile b/sysutils/thefish/Makefile
index 358db0c4a1c7..964d98a303a9 100644
--- a/sysutils/thefish/Makefile
+++ b/sysutils/thefish/Makefile
@@ -6,21 +6,27 @@
#
PORTNAME= thefish
-PORTVERSION= 0.5.1
-PORTREVISION= 1
+PORTVERSION= 0.6
CATEGORIES= sysutils
MASTER_SITES= http://www.energyhq.es.eu.org/files/
MAINTAINER= flynn@energyhq.es.eu.org
-COMMENT= Gtk+/ncurses rc.conf editor/management tool
+COMMENT= Qt/Gtk+/ncurses rc.conf editor/management tool
.if defined(WITHOUT_X11) || defined(NO_GUI)
NO_GUI= yes
MAKE_ENV+= NO_GUI=yes
.else
+.if !defined(WITH_QT)
USE_GNOME= gtk20
USE_X_PREFIX= yes
.endif
+.endif
+.if defined(WITH_QT)
+USE_QT_VER= 3
+MAKE_ENV+= WITH_QT=yes
+CXXFLAGS+= -Wall -DWITH_QT -I${X11BASE}/include
+.endif
MAN1= thefish.1
PLIST_FILES= bin/thefish
@@ -29,6 +35,10 @@ pre-everything::
.if !defined(WITHOUT_X11) && !defined(NO_GUI)
@${CAT} ${PKGMESSAGE}
.endif
+.if !defined(WITH_QT) && !defined(NO_GUI) && !defined(WITHOUT_X11)
+ @${ECHO_CMD} "- You can replace the GTK+ interface with a Qt version by defining WITH_QT"
+ @${ECHO_CMD}
+.endif
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/thefish ${PREFIX}/bin