aboutsummaryrefslogtreecommitdiff
path: root/sysutils/torsmo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/torsmo/Makefile')
-rw-r--r--sysutils/torsmo/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/sysutils/torsmo/Makefile b/sysutils/torsmo/Makefile
new file mode 100644
index 000000000000..060988df4a71
--- /dev/null
+++ b/sysutils/torsmo/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: torsmo
+# Date created: 2004-07-29
+# Whom: Roman Bogorodskiy <bogorodskiy@inbox.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= torsmo
+PORTVERSION= 0.17
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= bogorodskiy@inbox.ru
+COMMENT= System monitor that renders text on desktop
+
+USE_AUTOCONF_VER=259
+USE_AUTOMAKE_VER=14
+USE_X_PREFIX= yes
+MAN1= torsmo.1
+
+PLIST_FILES= bin/torsmo \
+ %%EXAMPLESDIR%%/torsmorc.sample
+PLIST_DIRS= %%EXAMPLESDIR%%
+PORTDOCS= AUTHORS ChangeLog NEWS README
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= does not build, use statvfs interface which is only present on FreeBSD 5.0 or newer
+.endif
+
+post-extract:
+ @${CP} ${FILESDIR}/freebsd.c ${WRKSRC}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/torsmorc.sample ${EXAMPLESDIR}
+
+.include <bsd.port.post.mk>