aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-rpi3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/u-boot-rpi3/Makefile')
-rw-r--r--sysutils/u-boot-rpi3/Makefile15
1 files changed, 13 insertions, 2 deletions
diff --git a/sysutils/u-boot-rpi3/Makefile b/sysutils/u-boot-rpi3/Makefile
index 838f27c36b5c..259344b24952 100644
--- a/sysutils/u-boot-rpi3/Makefile
+++ b/sysutils/u-boot-rpi3/Makefile
@@ -2,12 +2,14 @@
PORTNAME= u-boot
PORTVERSION= 2016.11
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ftp://ftp.denx.de/pub/u-boot/ \
LOCAL/db:bootfiles
PKGNAMESUFFIX= -rpi3
DISTFILES= u-boot-${PORTVERSION}.tar.bz2 \
- rpi3-boot-files-2016.05.tar.bz2:bootfiles
+ rpi3-boot-files-2016.05.tar.bz2:bootfiles \
+ rpi3-psci-monitor-master.tgz:bootfiles
MAINTAINER= db@FreeBSD.org
COMMENT= Cross-build U-Boot loader for RPi3
@@ -23,6 +25,8 @@ USES= gmake tar:bzip2
SSP_UNSAFE= yes # cross-LD does not support -fstack-protector
WRK_BOOTFILES= ${WRKDIR}/rpi3-boot-files-2016.05
+PSCI_MONITOR= rpi3-psci-monitor-master
+PSCI_DIR= ${WRKDIR}/${PSCI_MONITOR}
U_BOOT_DIR= share/u-boot/${PORTNAME}${PKGNAMESUFFIX}
PLIST_FILES= ${U_BOOT_DIR}/u-boot.bin \
@@ -37,14 +41,20 @@ PLIST_FILES= ${U_BOOT_DIR}/u-boot.bin \
${U_BOOT_DIR}/start_db.elf \
${U_BOOT_DIR}/start_x.elf \
${U_BOOT_DIR}/config.txt \
- ${U_BOOT_DIR}/LICENCE.broadcom
+ ${U_BOOT_DIR}/LICENCE.broadcom \
+ ${U_BOOT_DIR}/armstub8.bin
MAKE_ARGS+= ARCH=arm \
CROSS_COMPILE=aarch64-none-elf- \
CONFIG_EFI=y
do-configure:
+ (cd ${WRKDIR}; tar xvf ${DISTDIR}/${PSCI_MONITOR}.tgz)
(cd ${WRKSRC}; ${GMAKE} rpi_3_defconfig)
+do-build:
+ (cd ${WRKSRC}; ${GMAKE} ${MAKE_ARGS})
+ (cd ${PSCI_DIR}; ${MAKE})
+
# The output of the u-boot build process is u-boot.bin. Older firmware
# versions require a standard header, but the recent versions (our case)
# are capable of booting u-boot.bin directly. Also copy the entire
@@ -55,5 +65,6 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/u-boot.bin ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}/
${INSTALL_DATA} ${DESCR} ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}/README
${INSTALL_DATA} ${WRK_BOOTFILES}/* ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}
+ ${INSTALL_DATA} ${PSCI_DIR}/pscimon.bin ${STAGEDIR}/${PREFIX}/${U_BOOT_DIR}/armstub8.bin
.include <bsd.port.mk>