aboutsummaryrefslogtreecommitdiff
path: root/sysutils/uptimec/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/uptimec/Makefile')
-rw-r--r--sysutils/uptimec/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/sysutils/uptimec/Makefile b/sysutils/uptimec/Makefile
index 0f81d2823dab..a70fb0182682 100644
--- a/sysutils/uptimec/Makefile
+++ b/sysutils/uptimec/Makefile
@@ -6,24 +6,21 @@
#
PORTNAME= uptimec
-PORTVERSION= 0.1
+PORTVERSION= 0.2
CATEGORIES= sysutils
-MASTER_SITES= http://www.mrEriksson.net/downloads/
+MASTER_SITES= http://www.mrEriksson.net/downloads/ \
+ ftp://ftp.mrEriksson.net/pub/uptimec/
MAINTAINER= hsn@netmag.cz
COMMENT= Client for Uptime Project
GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
-USE_AUTOCONF_VER= 257
-USE_REINPLACE= yes
PLIST_FILES= sbin/uptimec etc/uptimecrc.sample etc/rc.d/uptimec.sh
PORTDOCS= README COPYING ChangeLog INSTALL protocol.txt
-post-patch:
- @${REINPLACE_CMD} -e 's|CC =|CC ?=|g' ${WRKSRC}/Makefile
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/uptimec ${PREFIX}/sbin
${INSTALL_DATA} ${MASTERDIR}/files/uptimecrc.sample ${PREFIX}/etc
@@ -37,6 +34,5 @@ do-install:
post-install:
@${SED} -e 's,%%LOCALBASE%%,${LOCALBASE},' ${PKGMESSAGE}
- ${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>