aboutsummaryrefslogtreecommitdiff
path: root/sysutils/usbhotkey/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/usbhotkey/Makefile')
-rw-r--r--sysutils/usbhotkey/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/sysutils/usbhotkey/Makefile b/sysutils/usbhotkey/Makefile
index 11388bbd364c..b13605a54c40 100644
--- a/sysutils/usbhotkey/Makefile
+++ b/sysutils/usbhotkey/Makefile
@@ -26,13 +26,15 @@ HAS_CONFIGURE= yes
.include <bsd.port.pre.mk>
.if !defined(WITHOUT_PTHREADS)
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} ${PTHREAD_CFLAGS} -I${LOCALBASE}/include \
- -I${LOCALBASE}/include/ruby-${RUBY_VER} -I${LOCALBASE}/include/ruby-${RUBY_VER}/${RUBY_ARCH}" \
- LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${LOCALBASE}/lib"
+CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/ruby-${RUBY_VER} \
+ -I${LOCALBASE}/include/ruby-${RUBY_VER}/${RUBY_ARCH}
+LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
.else
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include \
- -I${LOCALBASE}/include/ruby-${RUBY_VER} -I${LOCALBASE}/include/ruby-${RUBY_VER}/${RUBY_ARCH}" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include \
+ -I${LOCALBASE}/include/ruby-${RUBY_VER} \
+ -I${LOCALBASE}/include/ruby-${RUBY_VER}/${RUBY_ARCH}
+LDFLAGS+= -L${LOCALBASE}/lib
.endif
.if !defined(WITHOUT_GUI)