aboutsummaryrefslogtreecommitdiff
path: root/sysutils/vimpager/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/vimpager/Makefile')
-rw-r--r--sysutils/vimpager/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/sysutils/vimpager/Makefile b/sysutils/vimpager/Makefile
index 83fd5aee4627..cab4184f4810 100644
--- a/sysutils/vimpager/Makefile
+++ b/sysutils/vimpager/Makefile
@@ -13,14 +13,23 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= vim:${PORTSDIR}/editors/vim
-OPTIONS_DEFINE= VIMCAT
+OPTIONS_DEFINE= VIMCAT TACOS BOB BOB2 BOB3
OPTIONS_DEFAULT= VIMCAT
VIMCAT_DESC= Install vimcat(1) (requires shells/bash)
VIMCAT_RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
VIMCAT_PLIST_FILES= bin/vimcat man/man1/vimcat.1.gz
+VIMCAT_IMPLIES= TACOS
+TACOS_IMPLIES= BOB
+BOB_IMPLIES= BOB2
+BOB2_IMPLIES= BOB3
+TACOS_RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl
+
PLIST_FILES= bin/${PORTNAME} etc/${PORTNAME}rc man/man1/${PORTNAME}.1.gz
+.include <bsd.port.options.mk>
+bob:
+ @echo ${PORT_OPTIONS:M}
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/vimcat ${STAGEDIR}${PREFIX}/bin