aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/linux-procfs/Makefile28
-rw-r--r--sysutils/linux-procfs/distinfo.i3866
-rw-r--r--sysutils/linux-procfs/pkg-descr8
-rw-r--r--sysutils/linux-procfs/pkg-plist40
5 files changed, 83 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 498f879c15fd..77d77cc6148b 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -358,6 +358,7 @@
SUBDIR += linux-megacli
SUBDIR += linux-megamgr
SUBDIR += linux-nero
+ SUBDIR += linux-procfs
SUBDIR += linuxfdisk
SUBDIR += lire
SUBDIR += livecd
diff --git a/sysutils/linux-procfs/Makefile b/sysutils/linux-procfs/Makefile
new file mode 100644
index 000000000000..3fd2c6451d9e
--- /dev/null
+++ b/sysutils/linux-procfs/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: linux-procps
+# Date created: 2007-04-04
+# Whom: leres
+#
+# $FreeBSD$
+#
+
+PORTNAME= procps
+PORTVERSION= 3.2.5
+CATEGORIES= sysutils linux
+DISTNAME= ${PORTNAME}-${PORTVERSION}-6.4
+
+MAINTAINER= freebsd-emulation@FreeBSD.org
+COMMENT= Linux psproc binaries
+
+USE_LINUX_RPM= yes
+ONLY_FOR_ARCHS= i386
+LINUX_DIST_VER= 4
+USE_LDCONFIG= yes
+BRANDELF_DIRS= bin sbin usr/bin
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
+PROCFS= /compat/linux/proc
+
+post-install:
+ @df ${PROCFS} 2>&1 | ${EGREP} '^linprocfs ' > /dev/null 2>&1 || (echo ">>>" ; echo ">>> You still need to mount ${PROCFS}; see linprocfs(5)" ; echo ">>> for more information" ; echo ">>>")
+
+.include <bsd.port.mk>
diff --git a/sysutils/linux-procfs/distinfo.i386 b/sysutils/linux-procfs/distinfo.i386
new file mode 100644
index 000000000000..1c615096841e
--- /dev/null
+++ b/sysutils/linux-procfs/distinfo.i386
@@ -0,0 +1,6 @@
+MD5 (rpm/i386/fedora/4/procps-3.2.5-6.4.i386.rpm) = 62fb07e1743b4b22687bd01b9817951f
+SHA256 (rpm/i386/fedora/4/procps-3.2.5-6.4.i386.rpm) = 83c826a342f864db6bc6713828d258488f076859dcdb130169920aed9ad78d34
+SIZE (rpm/i386/fedora/4/procps-3.2.5-6.4.i386.rpm) = 207122
+MD5 (rpm/i386/fedora/4/procps-3.2.5-6.4.src.rpm) = 9f32ce3fdba3b3b7c8f69bbf768635cc
+SHA256 (rpm/i386/fedora/4/procps-3.2.5-6.4.src.rpm) = ce178db9f848b725f5e41d813b0429318221584a3dd8204a815412ba3ab6e821
+SIZE (rpm/i386/fedora/4/procps-3.2.5-6.4.src.rpm) = 305637
diff --git a/sysutils/linux-procfs/pkg-descr b/sysutils/linux-procfs/pkg-descr
new file mode 100644
index 000000000000..2ed15d276176
--- /dev/null
+++ b/sysutils/linux-procfs/pkg-descr
@@ -0,0 +1,8 @@
+This is a Linux/i386 rpm port of procps.
+
+ procps is the package that has a bunch of small useful utilities
+ that give information about processes using the /proc filesystem.
+ The package includes the programs ps, top, vmstat, w, kill,
+ free, slabtop, and skill.
+
+WWW: http://procps.sourceforge.net/
diff --git a/sysutils/linux-procfs/pkg-plist b/sysutils/linux-procfs/pkg-plist
new file mode 100644
index 000000000000..4d45bb6a3a06
--- /dev/null
+++ b/sysutils/linux-procfs/pkg-plist
@@ -0,0 +1,40 @@
+bin/ps
+lib/libproc-%%PORTVERSION%%.so
+sbin/sysctl
+usr/bin/free
+usr/bin/pgrep
+usr/bin/pkill
+usr/bin/pmap
+usr/bin/pwdx
+usr/bin/skill
+usr/bin/slabtop
+usr/bin/snice
+usr/bin/tload
+usr/bin/top
+usr/bin/uptime
+usr/bin/vmstat
+usr/bin/w
+usr/bin/watch
+usr/share/doc/procps-%%PORTVERSION%%/BUGS
+usr/share/doc/procps-%%PORTVERSION%%/FAQ
+usr/share/doc/procps-%%PORTVERSION%%/NEWS
+usr/share/doc/procps-%%PORTVERSION%%/TODO
+usr/share/man/man1/free.1.gz
+usr/share/man/man1/pgrep.1.gz
+usr/share/man/man1/pkill.1.gz
+usr/share/man/man1/pmap.1.gz
+usr/share/man/man1/ps.1.gz
+usr/share/man/man1/pwdx.1.gz
+usr/share/man/man1/skill.1.gz
+usr/share/man/man1/slabtop.1.gz
+usr/share/man/man1/snice.1.gz
+usr/share/man/man1/tload.1.gz
+usr/share/man/man1/top.1.gz
+usr/share/man/man1/uptime.1.gz
+usr/share/man/man1/w.1.gz
+usr/share/man/man1/watch.1.gz
+usr/share/man/man5/sysctl.conf.5.gz
+usr/share/man/man8/sysctl.8.gz
+usr/share/man/man8/vmstat.8.gz
+
+@dirrm usr/share/doc/procps-%%PORTVERSION%%