aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/asusoled/Makefile9
-rw-r--r--sysutils/lcdproc/Makefile4
-rw-r--r--sysutils/nut/Makefile4
-rw-r--r--sysutils/nut/files/extra-patch-m4_nut_check_libusb.m431
-rw-r--r--sysutils/nut22/Makefile4
-rw-r--r--sysutils/nut22/files/extra-patch-m4_nut_check_libusb.m431
-rw-r--r--sysutils/scanbuttond/Makefile10
-rw-r--r--sysutils/usbutils/Makefile6
8 files changed, 92 insertions, 7 deletions
diff --git a/sysutils/asusoled/Makefile b/sysutils/asusoled/Makefile
index 29be8076e83d..424d22d4870d 100644
--- a/sysutils/asusoled/Makefile
+++ b/sysutils/asusoled/Makefile
@@ -15,7 +15,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= jkim@FreeBSD.org
COMMENT= Utility for ASUS USB OLED Display
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
RUN_DEPENDS= ${FONTDIR}/TTF/luxisr.ttf:${PORTSDIR}/x11-fonts/font-bh-ttf
USE_SDL= image sdl ttf
@@ -30,6 +29,12 @@ MAKE_ARGS+= TTF_FONT=${FONTDIR}/TTF/luxisr.ttf
FONTDIR?= ${LOCALBASE}/lib/X11/fonts
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.endif
+
post-install:
.if !defined(NOPORTDATA)
@${MKDIR} ${DATADIR}
@@ -48,4 +53,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/lcdproc/Makefile b/sysutils/lcdproc/Makefile
index df32408bff54..8295ca912aba 100644
--- a/sysutils/lcdproc/Makefile
+++ b/sysutils/lcdproc/Makefile
@@ -65,7 +65,11 @@ LCDPROC_DRIVERS=bayrad \
.include <bsd.port.pre.mk>
.if defined(WITH_USB)
+. if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+. else
+CONFIGURE_ARGS+= --with-libusb-libraries=/usr
+. endif
CONFIGURE_ARGS+= --enable-libusb
PLIST_SUB+= USB=""
LCDPROC_DRIVERS+= IOWarrior
diff --git a/sysutils/nut/Makefile b/sysutils/nut/Makefile
index b08f0277bb44..1ab9b2aa0621 100644
--- a/sysutils/nut/Makefile
+++ b/sysutils/nut/Makefile
@@ -96,7 +96,11 @@ PLIST_SUB+= NUT_SERIAL="@comment "
.endif
.if !defined(WITHOUT_USB)
+. if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+. else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-m4_nut_check_libusb.m4
+. endif
CONFIGURE_ARGS+= --with-usb=auto
MAN8+= bcmxcp_usb.8 megatec_usb.8 richcomm_usb.8 tripplite_usb.8 \
usbhid-ups.8
diff --git a/sysutils/nut/files/extra-patch-m4_nut_check_libusb.m4 b/sysutils/nut/files/extra-patch-m4_nut_check_libusb.m4
new file mode 100644
index 000000000000..d6a89d6d8198
--- /dev/null
+++ b/sysutils/nut/files/extra-patch-m4_nut_check_libusb.m4
@@ -0,0 +1,31 @@
+--- m4/nut_check_libusb.m4.orig 2009-03-07 23:56:24.000000000 +0300
++++ m4/nut_check_libusb.m4 2009-03-07 23:57:04.000000000 +0300
+@@ -17,24 +17,12 @@
+
+ dnl Check for libusb libs and flags
+ AC_MSG_CHECKING(for libusb cflags)
+- CFLAGS=`libusb-config --cflags 2>/dev/null`
+- if (test "$?" != "0")
+- then
+- AC_MSG_RESULT(not found)
+- nut_have_libusb=no
+- else
+- AC_MSG_RESULT(${CFLAGS})
+- fi
++ CFLAGS=""
++ AC_MSG_RESULT(${CFLAGS})
+
+ AC_MSG_CHECKING(for libusb libs)
+- LDFLAGS=`libusb-config --libs 2>/dev/null`
+- if (test "$?" != "0")
+- then
+- AC_MSG_RESULT(not found)
+- nut_have_libusb=no
+- else
+- AC_MSG_RESULT(${LDFLAGS})
+- fi
++ LDFLAGS="-lusb"
++ AC_MSG_RESULT(${LDFLAGS})
+
+ if test "${nut_have_libusb}" = "yes"; then
+ LIBUSB_CFLAGS="${CFLAGS}"
diff --git a/sysutils/nut22/Makefile b/sysutils/nut22/Makefile
index b08f0277bb44..1ab9b2aa0621 100644
--- a/sysutils/nut22/Makefile
+++ b/sysutils/nut22/Makefile
@@ -96,7 +96,11 @@ PLIST_SUB+= NUT_SERIAL="@comment "
.endif
.if !defined(WITHOUT_USB)
+. if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+. else
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-m4_nut_check_libusb.m4
+. endif
CONFIGURE_ARGS+= --with-usb=auto
MAN8+= bcmxcp_usb.8 megatec_usb.8 richcomm_usb.8 tripplite_usb.8 \
usbhid-ups.8
diff --git a/sysutils/nut22/files/extra-patch-m4_nut_check_libusb.m4 b/sysutils/nut22/files/extra-patch-m4_nut_check_libusb.m4
new file mode 100644
index 000000000000..d6a89d6d8198
--- /dev/null
+++ b/sysutils/nut22/files/extra-patch-m4_nut_check_libusb.m4
@@ -0,0 +1,31 @@
+--- m4/nut_check_libusb.m4.orig 2009-03-07 23:56:24.000000000 +0300
++++ m4/nut_check_libusb.m4 2009-03-07 23:57:04.000000000 +0300
+@@ -17,24 +17,12 @@
+
+ dnl Check for libusb libs and flags
+ AC_MSG_CHECKING(for libusb cflags)
+- CFLAGS=`libusb-config --cflags 2>/dev/null`
+- if (test "$?" != "0")
+- then
+- AC_MSG_RESULT(not found)
+- nut_have_libusb=no
+- else
+- AC_MSG_RESULT(${CFLAGS})
+- fi
++ CFLAGS=""
++ AC_MSG_RESULT(${CFLAGS})
+
+ AC_MSG_CHECKING(for libusb libs)
+- LDFLAGS=`libusb-config --libs 2>/dev/null`
+- if (test "$?" != "0")
+- then
+- AC_MSG_RESULT(not found)
+- nut_have_libusb=no
+- else
+- AC_MSG_RESULT(${LDFLAGS})
+- fi
++ LDFLAGS="-lusb"
++ AC_MSG_RESULT(${LDFLAGS})
+
+ if test "${nut_have_libusb}" = "yes"; then
+ LIBUSB_CFLAGS="${CFLAGS}"
diff --git a/sysutils/scanbuttond/Makefile b/sysutils/scanbuttond/Makefile
index 8e773c233eac..960785bf580e 100644
--- a/sysutils/scanbuttond/Makefile
+++ b/sysutils/scanbuttond/Makefile
@@ -14,8 +14,6 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= dthiele@gmx.net
COMMENT= A daemon to monitor and configure modern scanner's buttons
-LIB_DEPENDS= usb-0.1.8:${PORTSDIR}/devel/libusb
-
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -23,10 +21,16 @@ USE_LDCONFIG= yes
SUB_FILES+= pkg-message
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
+.endif
+
pre-configure:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's|-ldl||g'
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/usbutils/Makefile b/sysutils/usbutils/Makefile
index ee636e9a5d99..c3538ffce15c 100644
--- a/sysutils/usbutils/Makefile
+++ b/sysutils/usbutils/Makefile
@@ -13,8 +13,6 @@ MASTER_SITE_SUBDIR= linux-usb
MAINTAINER= brix@FreeBSD.org
COMMENT= Utility for listing USB devices
-LIB_DEPENDS= usb-0.1:${PORTSDIR}/devel/libusb
-
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -25,6 +23,10 @@ PORTDOCS= AUTHORS ChangeLog NEWS README
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}