aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/graphicboot/Makefile5
-rw-r--r--sysutils/graphicboot/files/patch-Imakefile19
2 files changed, 22 insertions, 2 deletions
diff --git a/sysutils/graphicboot/Makefile b/sysutils/graphicboot/Makefile
index d6d238b1a00a..f120316accbc 100644
--- a/sysutils/graphicboot/Makefile
+++ b/sysutils/graphicboot/Makefile
@@ -7,13 +7,14 @@
PORTNAME= graphicboot
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= http://matt.sixxgate.com/files/
MAINTAINER= sixxgate@hotmail.com
COMMENT= Provides graphical X Window startup to FreeBSD during 'rc'
-RUN_DEPENDS= xloadimage:${PORTSDIR}/x11/xloadimage
+#RUN_DEPENDS= xloadimage:${PORTSDIR}/x11/xloadimage
USE_MOTIF= yes
USE_BZIP2= yes
@@ -29,6 +30,6 @@ BROKEN= The graphical boot requires rcorder which is only on FreeBSD 5 or great
.endif
post-install:
- ${CAT} pkg-message
+ @${CAT} pkg-message
.include <bsd.port.post.mk>
diff --git a/sysutils/graphicboot/files/patch-Imakefile b/sysutils/graphicboot/files/patch-Imakefile
new file mode 100644
index 000000000000..1aee936e76cb
--- /dev/null
+++ b/sysutils/graphicboot/files/patch-Imakefile
@@ -0,0 +1,19 @@
+--- Imakefile.orig Tue Apr 18 16:00:52 2006
++++ Imakefile Tue Apr 18 16:01:24 2006
+@@ -48,11 +48,11 @@
+ ComplexProgramTarget(graphicboot)
+
+ install::
+- $(INSTALL) $(INSTALLFLAGS) $(INSTPGMFLAGS) startgraphicboot $(RC_DDIR)/startgraphicboot
+- $(INSTALL) $(INSTALLFLAGS) $(INSTPGMFLAGS) endgraphicboot $(RC_DDIR)/endgraphicboot
++ $(INSTALL) $(INSTALLFLAGS) startgraphicboot $(RC_DDIR)/startgraphicboot
++ $(INSTALL) $(INSTALLFLAGS) endgraphicboot $(RC_DDIR)/endgraphicboot
+ $(MKDIRHIER) $(XBCONF)
+- $(INSTALL) $(INSTALLFLAGS) $(INSTPGMFLAGS) Xsplash.jpg $(XBCONF)/Xsplash.jpg
+- $(INSTALL) $(INSTALLFLAGS) $(INSTPGMFLAGS) Xresources $(XBCONF)/Xresources
+- $(INSTALL) $(INSTALLFLAGS) $(INSTPGMFLAGS) xorg.conf $(XBCONF)/xorg.conf
++ $(INSTALL) $(INSTALLFLAGS) Xsplash.jpg $(XBCONF)/Xsplash.jpg
++ $(INSTALL) $(INSTALLFLAGS) Xresources $(XBCONF)/Xresources
++ $(INSTALL) $(INSTALLFLAGS) xorg.conf $(XBCONF)/xorg.conf
+ $(LN) -f $(DESTDIR)$(BINDIR)/$(XSERVERNAME) $(XBCONF)/Xserver
+ chmod +x $(RC_DDIR)/startgraphicboot $(RC_DDIR)/endgraphicboot