aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/sleuthkit/Makefile8
-rw-r--r--sysutils/tct/Makefile4
2 files changed, 11 insertions, 1 deletions
diff --git a/sysutils/sleuthkit/Makefile b/sysutils/sleuthkit/Makefile
index bb9773fc08ec..7dae0ab5129b 100644
--- a/sysutils/sleuthkit/Makefile
+++ b/sysutils/sleuthkit/Makefile
@@ -20,6 +20,12 @@ MAN1= dcalc.1 dcat.1 dls.1 dstat.1 ffind.1 \
fls.1 fsstat.1 hfind.1 icat.1 ifind.1 \
ils.1 istat.1 mactime.1 mmls.1 sorter.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 600000
+BROKEN= "Does not build on FreeBSD >= 6.x"
+.endif
+
do-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/sleuthkit
@@ -32,4 +38,4 @@ do-install:
istat sha1 mmls file md5 ${PREFIX}/bin
cd ${WRKSRC}/man/man1 && ${INSTALL_MAN} ${MAN1} ${PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/tct/Makefile b/sysutils/tct/Makefile
index 1c43c532a301..1f042ef50ae2 100644
--- a/sysutils/tct/Makefile
+++ b/sysutils/tct/Makefile
@@ -24,6 +24,10 @@ MYPORTDOCS= CHANGES COPYRIGHT INSTALL LICENSE MANIFEST OS-NOTES README.FIRST TOD
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 600000
+BROKEN= "Does not build on FreeBSD >= 6.x"
+.endif
+
post-patch:
${SED} -e 's,/usr/local,${PREFIX},g' pkg-message > ${PKGMESSAGE}