aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/megarc/Makefile44
-rw-r--r--sysutils/megarc/distinfo2
-rw-r--r--sysutils/megarc/pkg-descr4
4 files changed, 51 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 650d46d79d5a..c28207a6ebf7 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -280,6 +280,7 @@
SUBDIR += mapchan
SUBDIR += mcron
SUBDIR += mdf2iso
+ SUBDIR += megarc
SUBDIR += memdump
SUBDIR += memfetch
SUBDIR += memgrep
diff --git a/sysutils/megarc/Makefile b/sysutils/megarc/Makefile
new file mode 100644
index 000000000000..036de52b55d9
--- /dev/null
+++ b/sysutils/megarc/Makefile
@@ -0,0 +1,44 @@
+# Ports collection makefile for: megarc
+# Date created: 22 June 2005
+# Whom: Gerrit Beine <tux@pinguru.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= megarc
+PORTVERSION= 1.51
+CATEGORIES= sysutils
+MASTER_SITES=
+DISTNAME= dr_freebsd_${PORTVERSION}
+
+MAINTAINER= tux@pinguru.net
+COMMENT= LSI Logic's MegaRAID controlling software
+
+USE_ZIP= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+ONLY_FOR_ARCHS= i386
+RESTRICTED= "Restrictive license"
+DOWNLOAD_URL= http://www.lsilogic.com/products/megaraid/
+
+PLIST_FILES= sbin/megarc
+PORTDOCS= *
+
+.include <bsd.port.pre.mk>
+
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+IGNORE= can not be automatically fetched due to licensing restrictions. You must manually fetch the distribution files from ${DOWNLOAD_URL} (Support -> Downloads -> freebsd151), place it in ${DISTDIR} and run make again
+.endif
+
+post-extract:
+ @cd ${WRKSRC} && ${UNZIP_CMD} -qo 'MegaRC 1.04.zip'
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/megarc ${PREFIX}/sbin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/Release\ History.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/megarc/distinfo b/sysutils/megarc/distinfo
new file mode 100644
index 000000000000..e92f547a3065
--- /dev/null
+++ b/sysutils/megarc/distinfo
@@ -0,0 +1,2 @@
+MD5 (dr_freebsd_1.51.zip) = 2ffadcdd7da8c491f954ee69a7e84851
+SIZE (dr_freebsd_1.51.zip) = 189120
diff --git a/sysutils/megarc/pkg-descr b/sysutils/megarc/pkg-descr
new file mode 100644
index 000000000000..8ad63c0b15d3
--- /dev/null
+++ b/sysutils/megarc/pkg-descr
@@ -0,0 +1,4 @@
+This port provides an utility for controlling most of the LSI Logic's
+MegaRAID BIOS functions.
+
+WWW: http://www.lsilogic.com/products/megaraid/