aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/ipmitool/Makefile39
-rw-r--r--sysutils/ipmitool/distinfo4
-rw-r--r--sysutils/ipmitool/pkg-descr11
4 files changed, 55 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 2bb53e253966..647d02b8f930 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -195,6 +195,7 @@
SUBDIR += idled
SUBDIR += installwatch
SUBDIR += ipa
+ SUBDIR += ipmitool
SUBDIR += ipsc
SUBDIR += jailadmin
SUBDIR += jailer
diff --git a/sysutils/ipmitool/Makefile b/sysutils/ipmitool/Makefile
new file mode 100644
index 000000000000..41f779f450e0
--- /dev/null
+++ b/sysutils/ipmitool/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: ipmitool
+# Date created: 25/Oct/2004
+# Whom: Dmitry Frolov <frol@nov.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipmitool
+PORTVERSION= 1.6.0
+CATEGORIES= sysutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+PATCH_SITES= ftp://ftp.riss-telecom.ru/pub/patches/
+PATCHFILES= ${DISTNAME}-fbsd1.diff
+
+MAINTAINER= frolov@riss-telecom.ru
+COMMENT= CLI to manage IPMI systems
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+# On FreeBSD only lan and lanplus interfaces are supported at this time
+CONFIGURE_ARGS+= --enable-intf-lan --enable-intf-lanplus \
+ --disable-intf-open --disable-intf-imb --disable-intf-lipmi
+PLIST_FILES= bin/ipmitool bin/ipmievd
+PLIST_DIRS= share/${PORTNAME}
+PORTDOCS= README AUTHORS ChangeLog COPYING
+MAN1+= ${PORTNAME}.1
+
+DATAFILES= bmclanconf ipmi.init README collect_data.sh \
+ create_rrds.sh create_webpage_compact.sh create_webpage.sh
+.for f in ${DATAFILES}
+PLIST_FILES+= share/${PORTNAME}/${f}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/sysutils/ipmitool/distinfo b/sysutils/ipmitool/distinfo
new file mode 100644
index 000000000000..d3d0cc8d9ebf
--- /dev/null
+++ b/sysutils/ipmitool/distinfo
@@ -0,0 +1,4 @@
+MD5 (ipmitool-1.6.0.tar.bz2) = 5f95cfc69531ee783eac5ec3939115b8
+SIZE (ipmitool-1.6.0.tar.bz2) = 358005
+MD5 (ipmitool-1.6.0-fbsd1.diff) = 12183edd1de2a6197ea9a5d19d64aa30
+SIZE (ipmitool-1.6.0-fbsd1.diff) = 5646
diff --git a/sysutils/ipmitool/pkg-descr b/sysutils/ipmitool/pkg-descr
new file mode 100644
index 000000000000..ab0ad3720f1c
--- /dev/null
+++ b/sysutils/ipmitool/pkg-descr
@@ -0,0 +1,11 @@
+Quoting IPMITool homepage:
+
+"IPMItool is a simple command-line interface to systems that support the
+Intelligent Platform Management Interface (IPMI) v1.5 specification. It
+provides the ability to read the SDR and print sensor values, display
+the contents of the SEL, print FRU information, read and set LAN
+configuration parameters, and perform chassis power control."
+
+Currently only LAN and LANPlus interfaces are supported on FreeBSD.
+
+WWW: http://ipmitool.sourceforge.net/