aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/u-boot-olinuxino-lime/Makefile14
-rw-r--r--sysutils/u-boot-olinuxino-lime/pkg-descr19
3 files changed, 34 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 26957b2017b0..d191a7c293a4 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -1111,6 +1111,7 @@
SUBDIR += u-boot-cubox-hummingboard
SUBDIR += u-boot-duovero
SUBDIR += u-boot-olimex-a20-som-evb
+ SUBDIR += u-boot-olinuxino-lime
SUBDIR += u-boot-orangepi-one
SUBDIR += u-boot-pandaboard
SUBDIR += u-boot-pine64
diff --git a/sysutils/u-boot-olinuxino-lime/Makefile b/sysutils/u-boot-olinuxino-lime/Makefile
new file mode 100644
index 000000000000..104e95e34733
--- /dev/null
+++ b/sysutils/u-boot-olinuxino-lime/Makefile
@@ -0,0 +1,14 @@
+# $FreeBSD$
+
+PKGNAMESUFFIX= -${MODEL}
+
+COMMENT= Cross-build U-Boot loader for Olinuxino Lime
+
+LICENSE= GPLv2
+
+MASTERDIR= ${.CURDIR}/../u-boot-olimex-a20-som-evb
+DESCR= ${.CURDIR}/pkg-descr
+MODEL= olinuxino-lime
+BOARD_CONFIG= A10-OLinuXino-Lime_defconfig
+
+.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/u-boot-olinuxino-lime/pkg-descr b/sysutils/u-boot-olinuxino-lime/pkg-descr
new file mode 100644
index 000000000000..1880c52a991b
--- /dev/null
+++ b/sysutils/u-boot-olinuxino-lime/pkg-descr
@@ -0,0 +1,19 @@
+U-Boot loader for Olinuxino Lime.
+
+To install this bootloader on an sdcard just do :
+dd if=/usr/local/share/u-boot/u-boot-boardname/u-boot-sunxi-with-spl.bin of=/path/to/sdcarddevice bs=1k seek=8 conv=notrunc,sync
+
+This version is patched so that:
+ * ELF and API features are enabled.
+ * The default environment is trimmed to just what's needed to boot.
+ * The saveenv command writes to the file u-boot.env on the FAT partition.
+ * The DTB file name is chosen based on the board model and passed to ubldr.bin
+ using the fdtfile env variable. ubldr.bin loads the DTB from /boot/dtb/ on
+ the FreeBSD partition.
+ * By default, it loads PIE ubldr.bin from file ubldr.bin on the FAT partition
+ to address 0x42000000, and launches it.
+
+For information about running FreeBSD on Allwinner boards, see
+ https://wiki.freebsd.org/FreeBSD/arm/Allwinner
+
+For general information about U-Boot see WWW: http://www.denx.de/wiki/U-Boot