aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cdrdao/Makefile4
-rw-r--r--sysutils/cdrdao/files/patch-scsilib_inc_avoffset.c28
-rw-r--r--sysutils/cdrdao/files/patch-scsilib_inc_getfp.c37
-rw-r--r--sysutils/cdrdao/files/patch-scsilib_libschily_getfp.c45
4 files changed, 112 insertions, 2 deletions
diff --git a/sysutils/cdrdao/Makefile b/sysutils/cdrdao/Makefile
index df6ae589ad90..d55fed9ef5c0 100644
--- a/sysutils/cdrdao/Makefile
+++ b/sysutils/cdrdao/Makefile
@@ -65,13 +65,13 @@ CONFIGURE_ARGS+= --with-mp3-support=no --with-ogg-support=no
.endif
.endif
+.include <bsd.port.pre.mk>
+
CONFIGURE_ARGS+= --without-pcctsbin --without-pcctsinc \
--with-posix-threads=no --with-scglib
MAKE_ENV= CCOM=cc
SCSILIBXARCH!= ${UNAME} -m
-.include <bsd.port.pre.mk>
-
post-extract:
@(cd ${WRKSRC}/scsilib/RULES && ${CP} os-freebsd.id os-dragonfly.id)
.if ${SCSILIBXARCH} != "i386"
diff --git a/sysutils/cdrdao/files/patch-scsilib_inc_avoffset.c b/sysutils/cdrdao/files/patch-scsilib_inc_avoffset.c
new file mode 100644
index 000000000000..dc87e3dfc225
--- /dev/null
+++ b/sysutils/cdrdao/files/patch-scsilib_inc_avoffset.c
@@ -0,0 +1,28 @@
+###########################################################################
+# This patch was contributed by Dimitry Andric.
+###########################################################################
+# The contents of this file are subject to the terms of the
+# Common Development and Distribution License, Version 1.0 only
+# (the "License"). You may not use this file except in compliance
+# with the License.
+#
+# See the file CDDL.Schily.txt in this distribution for details.
+#
+# When distributing Covered Code, include this CDDL HEADER in each
+# file and include the License file CDDL.Schily.txt from this distribution.
+###########################################################################
+# The file CDDL.Schily.txt can be found in the original cdrtools tarball,
+# which is mirrored at ftp://ftp.freebsd.org/pub/FreeBSD/distfiles/.
+###########################################################################
+
+--- scsilib/inc/avoffset.c.orig 2009-10-05 11:58:21 UTC
++++ scsilib/inc/avoffset.c
+@@ -61,7 +61,7 @@ main(ac, av)
+ {
+ int stdir;
+ #ifdef HAVE_SCANSTACK
+- register struct frame *fp;
++ volatile struct frame *fp;
+ register int i = 0;
+ register int o = 0;
+
diff --git a/sysutils/cdrdao/files/patch-scsilib_inc_getfp.c b/sysutils/cdrdao/files/patch-scsilib_inc_getfp.c
new file mode 100644
index 000000000000..5152d44295a5
--- /dev/null
+++ b/sysutils/cdrdao/files/patch-scsilib_inc_getfp.c
@@ -0,0 +1,37 @@
+###########################################################################
+# This patch was contributed by Dimitry Andric.
+###########################################################################
+# The contents of this file are subject to the terms of the
+# Common Development and Distribution License, Version 1.0 only
+# (the "License"). You may not use this file except in compliance
+# with the License.
+#
+# See the file CDDL.Schily.txt in this distribution for details.
+#
+# When distributing Covered Code, include this CDDL HEADER in each
+# file and include the License file CDDL.Schily.txt from this distribution.
+###########################################################################
+# The file CDDL.Schily.txt can be found in the original cdrtools tarball,
+# which is mirrored at ftp://ftp.freebsd.org/pub/FreeBSD/distfiles/.
+###########################################################################
+
+--- scsilib/inc/getfp.c.orig 2003-07-12 23:10:47 UTC
++++ scsilib/inc/getfp.c
+@@ -56,7 +56,7 @@
+
+ EXPORT void **___fpoff __PR((char *cp));
+
+-EXPORT void **
++EXPORT __noinline void **
+ getfp()
+ {
+ long **dummy[1];
+@@ -73,7 +73,7 @@ getfp()
+ * We need this function to fool GCCs check for returning addresses
+ * from outside the functions local address space.
+ */
+-EXPORT void **
++EXPORT __noinline void **
+ ___fpoff(cp)
+ char *cp;
+ {
diff --git a/sysutils/cdrdao/files/patch-scsilib_libschily_getfp.c b/sysutils/cdrdao/files/patch-scsilib_libschily_getfp.c
new file mode 100644
index 000000000000..beac9744a3fb
--- /dev/null
+++ b/sysutils/cdrdao/files/patch-scsilib_libschily_getfp.c
@@ -0,0 +1,45 @@
+###########################################################################
+# This patch was contributed by Dimitry Andric.
+###########################################################################
+# The contents of this file are subject to the terms of the
+# Common Development and Distribution License, Version 1.0 only
+# (the "License"). You may not use this file except in compliance
+# with the License.
+#
+# See the file CDDL.Schily.txt in this distribution for details.
+#
+# When distributing Covered Code, include this CDDL HEADER in each
+# file and include the License file CDDL.Schily.txt from this distribution.
+###########################################################################
+# The file CDDL.Schily.txt can be found in the original cdrtools tarball,
+# which is mirrored at ftp://ftp.freebsd.org/pub/FreeBSD/distfiles/.
+###########################################################################
+
+--- scsilib/libschily/getfp.c.orig 2003-07-12 23:10:47 UTC
++++ scsilib/libschily/getfp.c
+@@ -23,6 +23,7 @@
+ #include <mconfig.h>
+ #include <standard.h>
+ #include <schily.h>
++#include <sys/cdefs.h>
+
+ #ifndef IS_AVOFFSET
+ /*
+@@ -56,7 +57,7 @@
+
+ EXPORT void **___fpoff __PR((char *cp));
+
+-EXPORT void **
++EXPORT __noinline void **
+ getfp()
+ {
+ long **dummy[1];
+@@ -73,7 +74,7 @@ getfp()
+ * We need this function to fool GCCs check for returning addresses
+ * from outside the functions local address space.
+ */
+-EXPORT void **
++EXPORT __noinline void **
+ ___fpoff(cp)
+ char *cp;
+ {