aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/heartbeat/Makefile4
-rw-r--r--sysutils/heartbeat/files/patch-configure.in9
-rw-r--r--sysutils/syslog-ng-devel/Makefile7
-rw-r--r--sysutils/syslog-ng/Makefile7
-rw-r--r--sysutils/syslog-ng34/Makefile6
-rw-r--r--sysutils/syslog-ng35/Makefile7
6 files changed, 6 insertions, 34 deletions
diff --git a/sysutils/heartbeat/Makefile b/sysutils/heartbeat/Makefile
index 5893fe7175db..3985711fe331 100644
--- a/sysutils/heartbeat/Makefile
+++ b/sysutils/heartbeat/Makefile
@@ -41,8 +41,8 @@ INSTALL_TARGET= install-strip
USERS= hacluster
GROUPS= haclient
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libnet11
-LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/libnet11
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= --localstatedir=/var \
--with-miBsdir=${PREFIX}/snmp/mibs \
diff --git a/sysutils/heartbeat/files/patch-configure.in b/sysutils/heartbeat/files/patch-configure.in
index eb918671bd45..f5023631bf2f 100644
--- a/sysutils/heartbeat/files/patch-configure.in
+++ b/sysutils/heartbeat/files/patch-configure.in
@@ -50,15 +50,6 @@
AC_CHECK_PROGS(MAKE, gmake make)
AC_MSG_CHECKING(for gmake or make)
if test x"${MAKE}" = x""; then
-@@ -542,7 +538,7 @@
- AC_PATH_PROGS(MAILCMD, mail, mailx)
- AC_SUBST(MAILCMD)
- AC_DEFINE_UNQUOTED(IFCONFIG, "$IFCONFIG", path to the ifconfig command)
--AC_PATH_PROGS(LIBNETCONFIG, libnet-config)
-+AC_PATH_PROGS(LIBNETCONFIG, libnet11-config)
- AC_PATH_PROGS(GETENT, getent)
- AC_PATH_PROGS(IP2UTIL, ip, /sbin/ip)
- AC_PATH_PROGS(XML2CONFIG, xml2-config)
@@ -1718,6 +1714,7 @@
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)
diff --git a/sysutils/syslog-ng-devel/Makefile b/sysutils/syslog-ng-devel/Makefile
index 89ccfaad97ac..a7516f2e4d6a 100644
--- a/sysutils/syslog-ng-devel/Makefile
+++ b/sysutils/syslog-ng-devel/Makefile
@@ -64,10 +64,7 @@ CONFIGURE_ARGS+= --disable-tcp-wrapper
.if ${PORT_OPTIONS:MSPOOF}
LIB_DEPENDS+= libnet.so:${PORTSDIR}/net/libnet
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-CONFIGURE_ARGS+= --enable-spoof-source --with-libnet=${LOCALBASE}/bin
-CFLAGS+= `${LIBNET_CONFIG} --cflags` -I${LOCALBASE}/include
-LDFLAGS+= `${LIBNET_CONFIG} --libs`
+CONFIGURE_ARGS+= --enable-spoof-source
.else
CONFIGURE_ARGS+= --disable-spoof-source
.endif
@@ -148,8 +145,6 @@ CONFIGURE_ARGS+= --disable-python
.endif
post-patch:
- @${REINPLACE_CMD} -e 's:libnet-config:libnet11-config:g' \
- ${WRKSRC}/configure
@${CP} ${WRKSRC}/scl/syslog-ng.conf ${WRKSRC}/scl/syslog-ng.conf.dist
@${CP} ${WRKSRC}/scl/scl.conf ${WRKSRC}/scl/scl.conf.sample
diff --git a/sysutils/syslog-ng/Makefile b/sysutils/syslog-ng/Makefile
index 0e70b48c3b8d..897117255202 100644
--- a/sysutils/syslog-ng/Makefile
+++ b/sysutils/syslog-ng/Makefile
@@ -68,10 +68,7 @@ CONFIGURE_ARGS+= --disable-tcp-wrapper
.if ${PORT_OPTIONS:MSPOOF}
LIB_DEPENDS+= libnet.so:${PORTSDIR}/net/libnet
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-CONFIGURE_ARGS+= --enable-spoof-source --with-libnet=${LOCALBASE}/bin
-CFLAGS+= `${LIBNET_CONFIG} --cflags` -I${LOCALBASE}/include
-LDFLAGS+= `${LIBNET_CONFIG} --libs`
+CONFIGURE_ARGS+= --enable-spoof-source
.else
CONFIGURE_ARGS+= --disable-spoof-source
.endif
@@ -126,8 +123,6 @@ CONFIGURE_ARGS+= --disable-json
.endif
post-patch:
- @${REINPLACE_CMD} -e 's:libnet-config:libnet11-config:g' \
- ${WRKSRC}/configure
@${CP} ${WRKSRC}/scl/syslog-ng.conf ${WRKSRC}/scl/syslog-ng.conf.dist
@${CP} ${WRKSRC}/scl/scl.conf ${WRKSRC}/scl/scl.conf.sample
diff --git a/sysutils/syslog-ng34/Makefile b/sysutils/syslog-ng34/Makefile
index 8d36b50005bd..d81678c71929 100644
--- a/sysutils/syslog-ng34/Makefile
+++ b/sysutils/syslog-ng34/Makefile
@@ -65,10 +65,7 @@ CONFIGURE_ARGS+= --disable-tcp-wrapper
.if ${PORT_OPTIONS:MSPOOF}
LIB_DEPENDS+= libnet.so:${PORTSDIR}/net/libnet
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-CONFIGURE_ARGS+= --enable-spoof-source --with-libnet=${LOCALBASE}/bin
-CFLAGS+= `${LIBNET_CONFIG} --cflags` -I${LOCALBASE}/include
-LDFLAGS+= `${LIBNET_CONFIG} --libs`
+CONFIGURE_ARGS+= --enable-spoof-source
.else
CONFIGURE_ARGS+= --disable-spoof-source
.endif
@@ -121,7 +118,6 @@ CONFIGURE_ARGS+= --disable-json
.endif
post-patch:
- @${REINPLACE_CMD} -e 's:libnet-config:libnet11-config:g' ${WRKSRC}/configure
@${LN} ${WRKSRC}/scl/syslog-ng.conf ${WRKSRC}/scl/syslog-ng.conf.sample
@${LN} ${WRKSRC}/scl/scl.conf ${WRKSRC}/scl/scl.conf.sample
diff --git a/sysutils/syslog-ng35/Makefile b/sysutils/syslog-ng35/Makefile
index db81984f59ad..8e4f81bd3b82 100644
--- a/sysutils/syslog-ng35/Makefile
+++ b/sysutils/syslog-ng35/Makefile
@@ -69,10 +69,7 @@ CONFIGURE_ARGS+= --disable-tcp-wrapper
.if ${PORT_OPTIONS:MSPOOF}
LIB_DEPENDS+= libnet.so:${PORTSDIR}/net/libnet
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-CONFIGURE_ARGS+= --enable-spoof-source --with-libnet=${LOCALBASE}/bin
-CFLAGS+= `${LIBNET_CONFIG} --cflags` -I${LOCALBASE}/include
-LDFLAGS+= `${LIBNET_CONFIG} --libs`
+CONFIGURE_ARGS+= --enable-spoof-source
.else
CONFIGURE_ARGS+= --disable-spoof-source
.endif
@@ -135,8 +132,6 @@ CONFIGURE_ARGS+= --disable-json
.endif
post-patch:
- @${REINPLACE_CMD} -e 's:libnet-config:libnet11-config:g' \
- ${WRKSRC}/configure
@${CP} ${WRKSRC}/scl/syslog-ng.conf ${WRKSRC}/scl/syslog-ng.conf.dist
@${CP} ${WRKSRC}/scl/scl.conf ${WRKSRC}/scl/scl.conf.sample