aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/watchfolder/Makefile35
-rw-r--r--sysutils/watchfolder/distinfo2
-rw-r--r--sysutils/watchfolder/pkg-descr8
-rw-r--r--sysutils/watchfolder/pkg-plist7
5 files changed, 53 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index ef1639fd9bde..1eb9a750eaa3 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -533,6 +533,7 @@
SUBDIR += vttest
SUBDIR += wait_on
SUBDIR += watchdog
+ SUBDIR += watchfolder
SUBDIR += webjob
SUBDIR += webmin
SUBDIR += whatpix
diff --git a/sysutils/watchfolder/Makefile b/sysutils/watchfolder/Makefile
new file mode 100644
index 000000000000..1c13922231c1
--- /dev/null
+++ b/sysutils/watchfolder/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: watchfolder
+# Date created: 21 Jul 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= watchfolder
+PORTVERSION= 0.3.3
+CATEGORIES= sysutils
+MASTER_SITES= http://dstunrea.sdf-eu.org/files/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Watch folders for new files and process them
+
+WRKSRC= ${WRKDIR}/watchd-${PORTVERSION}
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|gcc $$(OPT)|${CC} ${CFLAGS}|' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|' \
+ ${WRKSRC}/README ${WRKSRC}/watchd.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/watchd ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/watchd.conf ${PREFIX}/etc/watchd.conf.sample
+ [ -f ${PREFIX}/etc/watchd.conf ] || \
+ ${INSTALL_DATA} ${WRKSRC}/watchd.conf ${PREFIX}/etc
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/doc/watchfolder.pdf ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/sysutils/watchfolder/distinfo b/sysutils/watchfolder/distinfo
new file mode 100644
index 000000000000..9af920fc0351
--- /dev/null
+++ b/sysutils/watchfolder/distinfo
@@ -0,0 +1,2 @@
+MD5 (watchfolder-0.3.3.tar.gz) = a1fd69af50b955c2da13381f16d27dfa
+SIZE (watchfolder-0.3.3.tar.gz) = 86741
diff --git a/sysutils/watchfolder/pkg-descr b/sysutils/watchfolder/pkg-descr
new file mode 100644
index 000000000000..5b4575956416
--- /dev/null
+++ b/sysutils/watchfolder/pkg-descr
@@ -0,0 +1,8 @@
+Watchfolder watches specified folders for incoming files and processes them
+with programs assigned to those folders. Afterwards, the files are removed
+from the inbound directory.
+
+WWW: http://freshmeat.net/projects/watchd/
+
+- ehaupt
+ehaupt@critical.ch
diff --git a/sysutils/watchfolder/pkg-plist b/sysutils/watchfolder/pkg-plist
new file mode 100644
index 000000000000..9838504de609
--- /dev/null
+++ b/sysutils/watchfolder/pkg-plist
@@ -0,0 +1,7 @@
+bin/watchd
+@unexec if cmp -s %D/etc/watchd.conf %D/etc/watchd.conf.sample; then rm -f %D/etc/watchd.conf; fi
+etc/watchd.conf.sample
+@exec [ -f %B/watchd.conf ] || cp %B/%f %B/watchd.conf
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/watchfolder.pdf
+%%PORTDOCS%%@dirrm %%DOCSDIR%%