aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/aaccli/Makefile4
-rw-r--r--sysutils/anteater/Makefile2
-rw-r--r--sysutils/ccd2iso/Makefile2
-rw-r--r--sysutils/cdf/Makefile2
-rw-r--r--sysutils/cfengine2/Makefile2
-rw-r--r--sysutils/dump9660/Makefile2
-rw-r--r--sysutils/grub/Makefile2
-rw-r--r--sysutils/hdup/Makefile2
-rw-r--r--sysutils/hourglass/Makefile2
-rw-r--r--sysutils/ipmitool/Makefile2
-rw-r--r--sysutils/k3b-kde4/Makefile2
-rw-r--r--sysutils/k3b/Makefile2
-rw-r--r--sysutils/linux-afaapps/Makefile8
-rw-r--r--sysutils/lookat/Makefile2
-rw-r--r--sysutils/metalog/Makefile2
-rw-r--r--sysutils/ntfsprogs/Makefile2
-rw-r--r--sysutils/nvtv/Makefile2
-rw-r--r--sysutils/pipemeter/Makefile2
-rw-r--r--sysutils/portdowngrade/Makefile2
-rw-r--r--sysutils/progsreiserfs/Makefile2
-rw-r--r--sysutils/rsnapshot/Makefile2
-rw-r--r--sysutils/sdd/Makefile6
-rw-r--r--sysutils/smartmontools-devel/Makefile2
-rw-r--r--sysutils/smartmontools/Makefile2
-rw-r--r--sysutils/srmt/Makefile6
-rw-r--r--sysutils/stress/Makefile2
-rw-r--r--sysutils/synergy/Makefile2
-rw-r--r--sysutils/testdisk/Makefile2
-rw-r--r--sysutils/uptimec/Makefile2
-rw-r--r--sysutils/userinfo/Makefile2
-rw-r--r--sysutils/wmfsm/Makefile2
-rw-r--r--sysutils/xvidcap/Makefile2
32 files changed, 40 insertions, 40 deletions
diff --git a/sysutils/aaccli/Makefile b/sysutils/aaccli/Makefile
index 263a947a4742..b563ea668dde 100644
--- a/sysutils/aaccli/Makefile
+++ b/sysutils/aaccli/Makefile
@@ -22,8 +22,8 @@ RESTRICTED= "May not be redistributed in binary form"
NO_CDROM= yes
ONLY_FOR_ARCHS= i386
-PLIST= ${MASTERDIR}/pkg-plist.${MACHINE_ARCH}
-MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
+PLIST= ${MASTERDIR}/pkg-plist.${ARCH}
+MD5_FILE= ${MASTERDIR}/distinfo.${ARCH}
NO_BUILD= yes
NO_WRKSUBDIR= yes
diff --git a/sysutils/anteater/Makefile b/sysutils/anteater/Makefile
index 998821e00f51..2511af830e05 100644
--- a/sysutils/anteater/Makefile
+++ b/sysutils/anteater/Makefile
@@ -17,7 +17,7 @@ COMMENT= A MTA log analyzer
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= anteater.1
PLIST_FILES= bin/anteater
diff --git a/sysutils/ccd2iso/Makefile b/sysutils/ccd2iso/Makefile
index c18d17fadcf7..550cefe2a861 100644
--- a/sysutils/ccd2iso/Makefile
+++ b/sysutils/ccd2iso/Makefile
@@ -19,7 +19,7 @@ COMMENT= A CloneCD to ISO converter
PLIST_FILES= bin/ccd2iso
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/ccd2iso ${PREFIX}/bin
diff --git a/sysutils/cdf/Makefile b/sysutils/cdf/Makefile
index 5be3114d2f7f..09be552c560f 100644
--- a/sysutils/cdf/Makefile
+++ b/sysutils/cdf/Makefile
@@ -16,6 +16,6 @@ COMMENT= A colorized df
PLIST_FILES= bin/cdf
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
.include <bsd.port.mk>
diff --git a/sysutils/cfengine2/Makefile b/sysutils/cfengine2/Makefile
index bad9c0f2275e..5bb269d7c967 100644
--- a/sysutils/cfengine2/Makefile
+++ b/sysutils/cfengine2/Makefile
@@ -17,7 +17,7 @@ COMMENT= A systems administration tool for networks
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-berkeleydb=${LOCALBASE} --with-docs
USE_REINPLACE= yes
diff --git a/sysutils/dump9660/Makefile b/sysutils/dump9660/Makefile
index 102a8029de03..3a3366e83d59 100644
--- a/sysutils/dump9660/Makefile
+++ b/sysutils/dump9660/Makefile
@@ -21,7 +21,7 @@ MLINKS= mk9660.8 dump9660.8
USE_REINPLACE= yes
ONLY_FOR_ARCHS= alpha i386 powerpc
-OBJTYPE= ${MACHINE_ARCH:S/i386/386/:S/powerpc/power/}
+OBJTYPE= ${ARCH:S/i386/386/:S/powerpc/power/}
MAKE_ENV= systype=${OPSYS} objtype=${OBJTYPE}
post-patch:
diff --git a/sysutils/grub/Makefile b/sysutils/grub/Makefile
index 633406fa4166..c43c92170620 100644
--- a/sysutils/grub/Makefile
+++ b/sysutils/grub/Makefile
@@ -17,7 +17,7 @@ USE_AUTOMAKE_VER= 19
USE_AUTOCONF_VER= 259
GNU_CONFIGURE= yes
USE_GMAKE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-freebsd-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-freebsd-freebsd${OSREL}
ONLY_FOR_ARCHS= i386
GRUB_DIR= ${DATADIR:C|^${PREFIX}/||}/i386-freebsd
diff --git a/sysutils/hdup/Makefile b/sysutils/hdup/Makefile
index eb87ddb37ec6..083cb5cb54a3 100644
--- a/sysutils/hdup/Makefile
+++ b/sysutils/hdup/Makefile
@@ -28,7 +28,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_GNOME= glib20
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_AUTOCONF_VER= 259
MAN1= hdup.1
diff --git a/sysutils/hourglass/Makefile b/sysutils/hourglass/Makefile
index cb337844ed6e..81a665d21f66 100644
--- a/sysutils/hourglass/Makefile
+++ b/sysutils/hourglass/Makefile
@@ -17,7 +17,7 @@ RUN_DEPENDS= jgraph:${PORTSDIR}/graphics/jgraph
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
PLIST_FILES= bin/busy bin/hourglass
PORTDOCS= CALIBRATION
diff --git a/sysutils/ipmitool/Makefile b/sysutils/ipmitool/Makefile
index 41f779f450e0..38a2269d93b2 100644
--- a/sysutils/ipmitool/Makefile
+++ b/sysutils/ipmitool/Makefile
@@ -21,7 +21,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
# On FreeBSD only lan and lanplus interfaces are supported at this time
CONFIGURE_ARGS+= --enable-intf-lan --enable-intf-lanplus \
--disable-intf-open --disable-intf-imb --disable-intf-lipmi
diff --git a/sysutils/k3b-kde4/Makefile b/sysutils/k3b-kde4/Makefile
index 8ae0298cd218..06b764a7bbd8 100644
--- a/sysutils/k3b-kde4/Makefile
+++ b/sysutils/k3b-kde4/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= mad:${PORTSDIR}/audio/libmad \
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-k3bsetup=no
USE_GMAKE= yes
USE_INC_LIBTOOL_VER=13
diff --git a/sysutils/k3b/Makefile b/sysutils/k3b/Makefile
index 8ae0298cd218..06b764a7bbd8 100644
--- a/sysutils/k3b/Makefile
+++ b/sysutils/k3b/Makefile
@@ -23,7 +23,7 @@ LIB_DEPENDS= mad:${PORTSDIR}/audio/libmad \
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-k3bsetup=no
USE_GMAKE= yes
USE_INC_LIBTOOL_VER=13
diff --git a/sysutils/linux-afaapps/Makefile b/sysutils/linux-afaapps/Makefile
index 319d1eec68d3..8376651b9fc6 100644
--- a/sysutils/linux-afaapps/Makefile
+++ b/sysutils/linux-afaapps/Makefile
@@ -11,7 +11,7 @@ PORTREVISION= 3
CATEGORIES= sysutils linux
MASTER_SITES= ftp://ftp.us.dell.com/scsi-raid/
PKGNAMEPREFIX= linux-
-DISTNAME= aacraid-util-rh8.0-${MACHINE_ARCH}
+DISTNAME= aacraid-util-rh8.0-${ARCH}
MAINTAINER= bms@FreeBSD.org
COMMENT= DELL PowerEdge Raid Controller 2 (apps)
@@ -32,10 +32,10 @@ LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
ONLY_FOR_ARCHS= i386
NO_FILTER_SHLIBS= yes
-PLIST= ${MASTERDIR}/pkg-plist.${MACHINE_ARCH}
-MD5_FILE= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
+PLIST= ${MASTERDIR}/pkg-plist.${ARCH}
+MD5_FILE= ${MASTERDIR}/distinfo.${ARCH}
-RPMFILE= ${PORTNAME}-${PORTVERSION}-2.${MACHINE_ARCH}.rpm
+RPMFILE= ${PORTNAME}-${PORTVERSION}-2.${ARCH}.rpm
DBPATH= /var/lib/rpm
RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
diff --git a/sysutils/lookat/Makefile b/sysutils/lookat/Makefile
index 2bb31670f08b..10846871441f 100644
--- a/sysutils/lookat/Makefile
+++ b/sysutils/lookat/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Lookat is a program to view Un*x text files and manual pages
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_REINPLACE= yes
diff --git a/sysutils/metalog/Makefile b/sysutils/metalog/Makefile
index 973e34252390..c3ff5f2086f7 100644
--- a/sysutils/metalog/Makefile
+++ b/sysutils/metalog/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
# Needed for metalog's configure to find installed devel/pcre port
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/sysutils/ntfsprogs/Makefile b/sysutils/ntfsprogs/Makefile
index a8d2028d702e..9ffaeca826f5 100644
--- a/sysutils/ntfsprogs/Makefile
+++ b/sysutils/ntfsprogs/Makefile
@@ -22,7 +22,7 @@ USE_GETOPT_LONG= yes
USE_INC_LIBTOOL_VER= 13
INSTALLS_SHLIB= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
OPTIONS= GNOMEVFS2 "Install Gnome-VFS-2.0 libntfs interface" off
diff --git a/sysutils/nvtv/Makefile b/sysutils/nvtv/Makefile
index 125c914fb0c2..3386b7d6d99b 100644
--- a/sysutils/nvtv/Makefile
+++ b/sysutils/nvtv/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= pci.2:${PORTSDIR}/devel/libpci
ONLY_FOR_ARCHS= i386
CONFIGURE_ENV= CC="${CC} -I${PREFIX}/include"
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
USE_LIBTOOL_VER= 15
USE_GETOPT_LONG= yes
diff --git a/sysutils/pipemeter/Makefile b/sysutils/pipemeter/Makefile
index b76908e311c1..e20b3fd381f0 100644
--- a/sysutils/pipemeter/Makefile
+++ b/sysutils/pipemeter/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= rabbi@abditum.com
COMMENT= Measure speed of data going through a pipe
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= pipemeter.1
PORTDOCS= Changelog README
diff --git a/sysutils/portdowngrade/Makefile b/sysutils/portdowngrade/Makefile
index 7ebf370b9eee..12195d6aef7f 100644
--- a/sysutils/portdowngrade/Makefile
+++ b/sysutils/portdowngrade/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ARGS+= --enable-default-server=${DEFAULT_CVS_SERVER}
.endif
GNU_CONFIGURE= yes
-CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET=--build=${ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
USE_BZIP2= yes
diff --git a/sysutils/progsreiserfs/Makefile b/sysutils/progsreiserfs/Makefile
index 46e5053a0342..dabc72fd216c 100644
--- a/sysutils/progsreiserfs/Makefile
+++ b/sysutils/progsreiserfs/Makefile
@@ -22,7 +22,7 @@ USE_GETOPT_LONG=yes
USE_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --disable-debug
.if defined(WITHOUT_NLS)
diff --git a/sysutils/rsnapshot/Makefile b/sysutils/rsnapshot/Makefile
index c26cd5cdb68d..7d4a9fd80557 100644
--- a/sysutils/rsnapshot/Makefile
+++ b/sysutils/rsnapshot/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= rsync:${PORTSDIR}/net/rsync
USE_PERL5= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= rsnapshot.1
DOCS= AUTHORS ChangeLog README TODO
diff --git a/sysutils/sdd/Makefile b/sysutils/sdd/Makefile
index 0b3c7924d1bd..db45b3993648 100644
--- a/sysutils/sdd/Makefile
+++ b/sysutils/sdd/Makefile
@@ -18,14 +18,14 @@ MAN1= sdd.1
.include <bsd.port.pre.mk>
-.if ${MACHINE_ARCH} != "i386" || ${CC} != "cc"
+.if ${ARCH} != "i386" || ${CC} != "cc"
post-extract:
@${LN} -sf i386-freebsd-cc.rul \
- ${WRKSRC}/RULES/${MACHINE_ARCH}-freebsd-${CC}.rul
+ ${WRKSRC}/RULES/${ARCH}-freebsd-${CC}.rul
.endif
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/sdd/OBJ/${MACHINE_ARCH}-freebsd-${CC}/sdd \
+ ${INSTALL_PROGRAM} ${WRKSRC}/sdd/OBJ/${ARCH}-freebsd-${CC}/sdd \
${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/sdd/sdd.1 ${PREFIX}/man/man1
diff --git a/sysutils/smartmontools-devel/Makefile b/sysutils/smartmontools-devel/Makefile
index 69fd570cf759..e1321e9fa2eb 100644
--- a/sysutils/smartmontools-devel/Makefile
+++ b/sysutils/smartmontools-devel/Makefile
@@ -20,7 +20,7 @@ USE_RC_SUBR= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-initscriptdir=${PREFIX}/etc/rc.d \
--with-docdir=${DOCSDIR} --enable-sample
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
PROGRAMS= smartctl smartd
MAN5= smartd.conf.5
diff --git a/sysutils/smartmontools/Makefile b/sysutils/smartmontools/Makefile
index 69fd570cf759..e1321e9fa2eb 100644
--- a/sysutils/smartmontools/Makefile
+++ b/sysutils/smartmontools/Makefile
@@ -20,7 +20,7 @@ USE_RC_SUBR= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-initscriptdir=${PREFIX}/etc/rc.d \
--with-docdir=${DOCSDIR} --enable-sample
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
PROGRAMS= smartctl smartd
MAN5= smartd.conf.5
diff --git a/sysutils/srmt/Makefile b/sysutils/srmt/Makefile
index dfb610f55727..ae051ed02f80 100644
--- a/sysutils/srmt/Makefile
+++ b/sysutils/srmt/Makefile
@@ -22,9 +22,9 @@ MAKE_ENV= MAKEPROG=${GMAKE} CCOM=${CC}
MAN1= srmt.1
post-extract:
-.if ${MACHINE_ARCH} != "i386" || ${CC} != "cc"
+.if ${ARCH} != "i386" || ${CC} != "cc"
@${LN} -sf i386-freebsd-cc.rul \
- ${WRKSRC}/RULES/${MACHINE_ARCH}-freebsd-${CC}.rul
+ ${WRKSRC}/RULES/${ARCH}-freebsd-${CC}.rul
.endif
post-patch:
@@ -34,7 +34,7 @@ post-patch:
do-install:
@${INSTALL_PROGRAM} \
- ${WRKSRC}/rmt/OBJ/${MACHINE_ARCH}-freebsd-${CC}/rmt \
+ ${WRKSRC}/rmt/OBJ/${ARCH}-freebsd-${CC}/rmt \
${PREFIX}/sbin/srmt
@${INSTALL_MAN} ${WRKSRC}/rmt/rmt.1 ${MANPREFIX}/man/man1/srmt.1
@${INSTALL_DATA} ${WRKSRC}/rmt/rmt.dfl ${PREFIX}/etc/srmt.conf.dist
diff --git a/sysutils/stress/Makefile b/sysutils/stress/Makefile
index 772e781d9a07..a935601b325d 100644
--- a/sysutils/stress/Makefile
+++ b/sysutils/stress/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= setagllib@optusnet.com.au
COMMENT= Tool to impose load on and stress test Unix-like systems
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build ${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build ${ARCH}-portbld-freebsd${OSREL}
INFO= stress
MAN1= stress.1
diff --git a/sysutils/synergy/Makefile b/sysutils/synergy/Makefile
index f4e37a693733..f72736961240 100644
--- a/sysutils/synergy/Makefile
+++ b/sysutils/synergy/Makefile
@@ -16,7 +16,7 @@ COMMENT= Mouse and keyboard sharing utility
GNU_CONFIGURE= yes
USE_X_PREFIX= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
DOCS= AUTHORS COPYING ChangeLog INSTALL NEWS README
diff --git a/sysutils/testdisk/Makefile b/sysutils/testdisk/Makefile
index 4c8c5cb0ad4a..2516cf3db3ca 100644
--- a/sysutils/testdisk/Makefile
+++ b/sysutils/testdisk/Makefile
@@ -15,7 +15,7 @@ COMMENT= Tool to check and undelete partitions
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${PREFIX}/include" LDFLAGS="-L${PREFIX}/lib"
MAN1= testdisk.1 photorec.1
diff --git a/sysutils/uptimec/Makefile b/sysutils/uptimec/Makefile
index 6633e4a00d12..82048463aede 100644
--- a/sysutils/uptimec/Makefile
+++ b/sysutils/uptimec/Makefile
@@ -18,7 +18,7 @@ USE_RC_SUBR= yes
USE_REINPLACE= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
PLIST_FILES= sbin/uptimec etc/uptimecrc.sample etc/rc.d/uptimec.sh
PORTDOCS= README ChangeLog INSTALL protocol.txt
diff --git a/sysutils/userinfo/Makefile b/sysutils/userinfo/Makefile
index 74f19d629d35..e9bb549317c8 100644
--- a/sysutils/userinfo/Makefile
+++ b/sysutils/userinfo/Makefile
@@ -14,7 +14,7 @@ MAINTAINER= bjk@m-net.arbornet.org
COMMENT= Show information about local users
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
MAN1= ui.1
PLIST_FILES= bin/ui
diff --git a/sysutils/wmfsm/Makefile b/sysutils/wmfsm/Makefile
index 02798363fdea..a0694f0f1ba6 100644
--- a/sysutils/wmfsm/Makefile
+++ b/sysutils/wmfsm/Makefile
@@ -17,7 +17,7 @@ USE_X_PREFIX= yes
USE_XPM= yes
USE_GETOPT_LONG= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= wmfsm.1
diff --git a/sysutils/xvidcap/Makefile b/sysutils/xvidcap/Makefile
index d488c0b5e734..dfd155c4752b 100644
--- a/sysutils/xvidcap/Makefile
+++ b/sysutils/xvidcap/Makefile
@@ -21,7 +21,7 @@ COMMENT= Capture your X display to individual frames or MPEG video
RUN_DEPENDS= animate:${PORTSDIR}/graphics/ImageMagick
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
#CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
# LDFLAGS=-L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-forced-embedded-ffmpeg # To be removed after 1.1.4pre2?