aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/x86info/Makefile2
-rw-r--r--sysutils/x86info/distinfo5
-rw-r--r--sysutils/x86info/files/patch-cpuid.c11
3 files changed, 15 insertions, 3 deletions
diff --git a/sysutils/x86info/Makefile b/sysutils/x86info/Makefile
index 42ed75ef161d..cda5f8a688e7 100644
--- a/sysutils/x86info/Makefile
+++ b/sysutils/x86info/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= x86info
-PORTVERSION= 1.16
+PORTVERSION= 1.17
CATEGORIES= sysutils
MASTER_SITES= http://www.codemonkey.org.uk/projects/x86info/ \
${MASTER_SITE_SOURCEFORGE}
diff --git a/sysutils/x86info/distinfo b/sysutils/x86info/distinfo
index a3bb85d080e4..0ca267c67ee2 100644
--- a/sysutils/x86info/distinfo
+++ b/sysutils/x86info/distinfo
@@ -1,2 +1,3 @@
-MD5 (x86info-1.16.tgz) = 57cfb84b006f0f5634ee8bd458330328
-SIZE (x86info-1.16.tgz) = 51410
+MD5 (x86info-1.17.tgz) = bef27fba7b0c3a9aeda63372a670f3a9
+SHA256 (x86info-1.17.tgz) = c9f7a0183af65b8e7777757a9abe593caed7c4696d4af7421871243785aadeff
+SIZE (x86info-1.17.tgz) = 51625
diff --git a/sysutils/x86info/files/patch-cpuid.c b/sysutils/x86info/files/patch-cpuid.c
new file mode 100644
index 000000000000..c7938b5b540b
--- /dev/null
+++ b/sysutils/x86info/files/patch-cpuid.c
@@ -0,0 +1,11 @@
+--- cpuid.c.orig Sat Nov 26 20:51:01 2005
++++ cpuid.c Sat Nov 26 20:51:24 2005
+@@ -40,7 +40,7 @@
+ snprintf (cpuname,18, "/dev/cpu/%d/cpuid", CPU_number);
+ fh = open (cpuname, O_RDONLY);
+ if (fh != -1) {
+- lseek64 (fh, (off64_t)idx, SEEK_CUR);
++ lseek (fh, (off_t)idx, SEEK_CUR);
+ read (fh, &buffer[0], 16);
+ if (eax!=0) *eax = (*(unsigned *)(buffer ));
+ if (ebx!=0) *ebx = (*(unsigned *)(buffer+ 4));