aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/ansible/Makefile32
-rw-r--r--sysutils/ansible/distinfo4
-rw-r--r--sysutils/ansible1/Makefile17
-rw-r--r--sysutils/ansible1/distinfo2
5 files changed, 41 insertions, 15 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index a3d1faedc4ac..eb2639902c04 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -31,6 +31,7 @@
SUBDIR += anacron
SUBDIR += and
SUBDIR += ansible
+ SUBDIR += ansible1
SUBDIR += apachetop
SUBDIR += apcpwr
SUBDIR += apcupsd
diff --git a/sysutils/ansible/Makefile b/sysutils/ansible/Makefile
index b31d5df4afb8..efd7bf023d46 100644
--- a/sysutils/ansible/Makefile
+++ b/sysutils/ansible/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= ansible
-PORTVERSION= 1.9.4
-PORTREVISION= 1
+PORTVERSION?= 2.0.0.0
CATEGORIES= sysutils python
MASTER_SITES= http://releases.ansible.com/ansible/
@@ -13,19 +12,23 @@ COMMENT= Radically simple IT automation
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS+= a2x:${PORTSDIR}/textproc/asciidoc \
+ xsltproc:${PORTSDIR}/textproc/libxslt \
+ docbook-xml>0:${PORTSDIR}/textproc/docbook-xml \
+ ${LOCALBASE}/share/xsl/docbook/manpages/docbook.xsl:${PORTSDIR}/textproc/docbook-xsl
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
${PYTHON_PKGNAMEPREFIX}pycrypto>0:${PORTSDIR}/security/py-pycrypto \
${PYTHON_PKGNAMEPREFIX}paramiko>0:${PORTSDIR}/security/py-paramiko \
${PYTHON_PKGNAMEPREFIX}Jinja2>0:${PORTSDIR}/devel/py-Jinja2
-OPTIONS_DEFINE= EXAMPLES
+OPTIONS_DEFINE= DOCS EXAMPLES
NO_ARCH= yes
USES= cpe python:2 shebangfix
USE_PYTHON= autoplist distutils
python_CMD= ${LOCALBASE}/bin/python
-SHEBANG_FILES= lib/ansible/runner/action_plugins/synchronize.py \
- lib/ansible/modules/core/*/*.py \
+SHEBANG_FILES+= lib/ansible/modules/core/*/*.py \
lib/ansible/modules/core/*/*/*.py \
lib/ansible/modules/extras/*/*.py \
lib/ansible/modules/extras/*/*/*.py
@@ -43,20 +46,23 @@ PLIST_FILES+= man/man1/ansible-doc.1.gz \
PORTEXAMPLES= ansible.cfg hosts
post-patch:
-.for f in bin/ansible-galaxy docs/man/man1/ansible-galaxy.1 \
- docs/man/man1/ansible-playbook.1 docs/man/man1/ansible.1 \
- examples/ansible.cfg examples/hosts lib/ansible/constants.py \
- lib/ansible/module_utils/urls.py lib/ansible/modules/core/system/setup.py \
- lib/ansible/playbook/__init__.py lib/ansible/runner/__init__.py
+.for f in bin/* docs/man/man1/* examples/* lib/ansible/*.py \
+ lib/ansible/*/*.py lib/ansible/*/*/*.py lib/ansible/*/*/*/*.py
@${REINPLACE_CMD} -e 's|/etc/ansible|${ETCDIR}|' ${WRKSRC}/${f}
.endfor
-.for f in docs/man/man1/ansible-playbook.1 docs/man/man1/ansible.1 \
- examples/ansible.cfg lib/ansible/constants.py \
- lib/ansible/playbook/__init__.py lib/ansible/runner/__init__.py \
+.for f in docs/man/man1/* examples/* lib/ansible/*.py lib/ansible/*/*.py
@${REINPLACE_CMD} -e 's|/usr/share/ansible|${DATADIR}|' ${WRKSRC}/${f}
.endfor
+post-build:
+.for f in ansible-doc ansible-galaxy ansible-playbook ansible-pull \
+ ansible-vault ansible
+ ${LOCALBASE}/bin/a2x -d manpage -f manpage -L \
+ ${WRKSRC}/docs/man/man1/${f}.1.asciidoc.in
+ ${RM} ${WRKSRC}/docs/man/man1/${f}.1.asciidoc.in
+.endfor
+
post-install:
@${MKDIR} ${STAGEDIR}${MAN1PREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/docs/man/man1/*.1 \
diff --git a/sysutils/ansible/distinfo b/sysutils/ansible/distinfo
index cb07d8c87d82..9f6c04d0442a 100644
--- a/sysutils/ansible/distinfo
+++ b/sysutils/ansible/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ansible-1.9.4.tar.gz) = 972c2face49f1577bd0ff7989440bfe2820e66fb10d7579915cc536bccfa6fe3
-SIZE (ansible-1.9.4.tar.gz) = 937120
+SHA256 (ansible-2.0.0.0.tar.gz) = 63a9386ae96bd6ae3e87b9e9fecef3f3f919f333ed8db22292e37df7643cb3f6
+SIZE (ansible-2.0.0.0.tar.gz) = 1512605
diff --git a/sysutils/ansible1/Makefile b/sysutils/ansible1/Makefile
new file mode 100644
index 000000000000..0b1647d5fa8d
--- /dev/null
+++ b/sysutils/ansible1/Makefile
@@ -0,0 +1,17 @@
+--- sysutils/ansible1/Makefile
++++ sysutils/ansible1/Makefile
+@@ -0,0 +1,14 @@
++# Created by: Nikolai Lifanov <lifanov@mail.lifanov.com>
++# $FreeBSD$
++
++PKGNAMESUFFIX= 1
++PORTVERSION= 1.9.4
++
++CONFLICTS= ansible-*
++
++MASTERDIR= ${.CURDIR}/../ansible
++DISTINFO_FILE= ${.CURDIR}/distinfo
++
++SHEBANG_FILES= lib/ansible/runner/action_plugins/synchronize.py
++
++.include "${MASTERDIR}/Makefile"
diff --git a/sysutils/ansible1/distinfo b/sysutils/ansible1/distinfo
new file mode 100644
index 000000000000..cb07d8c87d82
--- /dev/null
+++ b/sysutils/ansible1/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ansible-1.9.4.tar.gz) = 972c2face49f1577bd0ff7989440bfe2820e66fb10d7579915cc536bccfa6fe3
+SIZE (ansible-1.9.4.tar.gz) = 937120