aboutsummaryrefslogtreecommitdiff
path: root/sysutils
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils')
-rw-r--r--sysutils/cpdup/Makefile8
-rw-r--r--sysutils/cpdup/files/patch-Makefile10
-rw-r--r--sysutils/cpdup/files/patch-hclink.c13
3 files changed, 23 insertions, 8 deletions
diff --git a/sysutils/cpdup/Makefile b/sysutils/cpdup/Makefile
index 5333f951fbaf..4756b2397846 100644
--- a/sysutils/cpdup/Makefile
+++ b/sysutils/cpdup/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: cpdup
-# Date created: 28 Oct 1999
-# Whom: dillon
-#
+# Created by: Matthew Dillon <dillon@backplane.com>
# $FreeBSD$
-#
PORTNAME= cpdup
PORTVERSION= 1.17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= http://apollo.backplane.com/FreeSrc/ \
http://utenti.gufi.org/~gmarco/files/distfiles/
diff --git a/sysutils/cpdup/files/patch-Makefile b/sysutils/cpdup/files/patch-Makefile
new file mode 100644
index 000000000000..be1fe39f2bc2
--- /dev/null
+++ b/sysutils/cpdup/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig 2010-07-05 20:02:07.000000000 +0200
++++ Makefile 2012-11-05 13:35:55.997489741 +0100
+@@ -6,6 +6,7 @@
+
+ .if defined(.FreeBSD)
+ CFLAGS += -D_ST_FLAGS_PRESENT_=1
++NO_WERROR = true
+ WARNS?= 6
+ .endif
+
diff --git a/sysutils/cpdup/files/patch-hclink.c b/sysutils/cpdup/files/patch-hclink.c
index c69fc19c5e56..aab08e6588d2 100644
--- a/sysutils/cpdup/files/patch-hclink.c
+++ b/sysutils/cpdup/files/patch-hclink.c
@@ -1,5 +1,14 @@
---- ./hclink.c.orig 2010-09-25 18:01:27.989863475 -0400
-+++ ./hclink.c 2010-09-25 18:01:46.138176079 -0400
+--- hclink.c.orig 2010-07-19 21:01:56.000000000 +0200
++++ hclink.c 2012-11-05 13:16:09.731500043 +0100
+@@ -49,7 +49,7 @@
+ av[n++] = "-C";
+ for (m = 0; m < ssh_argc; m++)
+ av[n++] = ssh_argv[m];
+- av[n++] = "-T";
++ av[n++] = "--";
+ av[n++] = hc->host;
+ av[n++] = "cpdup";
+ av[n++] = (readonly ? "-RS" : "-S");
@@ -388,7 +388,7 @@
hcc_check_space(hctransaction_t trans, struct HCHead *head, int n, int size)
{