aboutsummaryrefslogtreecommitdiff
path: root/textproc/bib2html/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/bib2html/Makefile')
-rw-r--r--textproc/bib2html/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/textproc/bib2html/Makefile b/textproc/bib2html/Makefile
index 919e34516364..ec536ff1b1cf 100644
--- a/textproc/bib2html/Makefile
+++ b/textproc/bib2html/Makefile
@@ -7,15 +7,16 @@
#
PORTNAME= bib2html
-PORTVERSION= 3.3
+DISTVERSION= 4.1-1
CATEGORIES= textproc print
-MASTER_SITES= http://galland.stephane.free.fr/arakhne.org/bib2html/ \
- http://fresh.t-systems-sfr.com/unix/src/privat2/
+MASTER_SITES= http://www.arakhne.org/IMG/gz/ \
+ http://fresh.t-systems-sfr.com/fresh/unix/src/privat2/
+DISTFILES= ${PORTNAME}_${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= The BibTeX to HTML Translator
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+WRKSRC= ${WRKDIR}/${PORTNAME}-4.1/src
USE_PERL5_RUN= yes
NO_BUILD= yes
@@ -23,9 +24,12 @@ NO_BUILD= yes
post-patch:
@${SED} -e 's:= "$$0";:= "${SITE_PERL}/Bib2HTML";:g' \
< ${WRKSRC}/bib2html.pl > ${WRKSRC}/bib2html
+ @${SED} -e 's:= "$$0";:= "${SITE_PERL}/Bib2HTML";:g' \
+ < ${WRKSRC}/bib2xml.pl > ${WRKSRC}/bib2xml
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/bib2html ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bib2xml ${PREFIX}/bin
@${MKDIR} ${SITE_PERL}/Bib2HTML
@cd ${WRKSRC}/Bib2HTML && ${FIND} . | \
${CPIO} -pdm -L -R ${LIBOWN}:${LIBGRP} ${SITE_PERL}/Bib2HTML